<!DOCTYPE html>
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0">
	    <meta name="theme-color" content="#9aabb8"/>	<link rel="profile" href="http://gmpg.org/xfn/11" />
	<link rel="pingback" href="http://www.ktrs.com/xmlrpc.php" />
            <script type="text/javascript">
            var originalAddEventListener, oldWidth;

            if (/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent)) {
                originalAddEventListener = EventTarget.prototype.addEventListener;
                oldWidth = window.innerWidth;

                EventTarget.prototype.addEventListener = function (eventName, eventHandler) {
                    originalAddEventListener.call(this, eventName, function (event) {
                        if (event.type === "resize" && oldWidth === window.innerWidth) {
                            return;
                        }
                        else if (event.type === "resize" && oldWidth !== window.innerWidth) {
                            oldWidth = window.innerWidth;
                        }
                        eventHandler(event);
                    });
                };
            }
        </script>
		<title>Trump Lauds Firing Of Ex-Top FBI Official As &#039;Great Day&#039; - KTRS | St Louis News and Talk Radio | The Big 550 AM</title>
<script type="text/javascript">
function createCookie(a,d,b){if(b){var c=new Date;c.setTime(c.getTime()+864E5*b);b="; expires="+c.toGMTString()}else b="";document.cookie=a+"="+d+b+"; path=/"}function readCookie(a){a+="=";for(var d=document.cookie.split(";"),b=0;b<d.length;b++){for(var c=d[b];" "==c.charAt(0);)c=c.substring(1,c.length);if(0==c.indexOf(a))return c.substring(a.length,c.length)}return null}function eraseCookie(a){createCookie(a,"",-1)}
function areCookiesEnabled(){var a=!1;createCookie("testing","Hello",1);null!=readCookie("testing")&&(a=!0,eraseCookie("testing"));return a}(function(a){var d=readCookie("devicePixelRatio"),b=void 0===a.devicePixelRatio?1:a.devicePixelRatio;areCookiesEnabled()&&null==d&&(createCookie("devicePixelRatio",b,7),1!=b&&a.location.reload(!0))})(window);
</script>
<!-- This site is optimized with the Yoast SEO plugin v7.0.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.ktrs.com/trump-lauds-firing-of-ex-top-fbi-official-as-great-day/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Trump Lauds Firing Of Ex-Top FBI Official As &#039;Great Day&#039; - KTRS | St Louis News and Talk Radio | The Big 550 AM" />
<meta property="og:description" content="By ERIC TUCKER, Associated Press WASHINGTON (AP) — Attorney General Jeff Sessions says he has fired Andrew McCabe, a former FBI deputy director who was a regular target of President Donald Trump&#8217;s anger and criticism, just two days before McCabe&#8217;s scheduled retirement date. McCabe suggested the move was part of the Trump administration&#8217;s &#8220;war on the&hellip;" />
<meta property="og:url" content="http://www.ktrs.com/trump-lauds-firing-of-ex-top-fbi-official-as-great-day/" />
<meta property="og:site_name" content="KTRS | St Louis News and Talk Radio | The Big 550 AM" />
<meta property="article:tag" content="Andrew McCabe" />
<meta property="article:tag" content="FBI" />
<meta property="article:tag" content="Jeff Sessions" />
<meta property="article:tag" content="President Trump" />
<meta property="article:section" content="Home - National" />
<meta property="article:published_time" content="2018-03-17T08:47:55-05:00" />
<meta property="og:image" content="http://www.ktrs.com/wp-content/uploads/2018/03/Andrew-McCabe.jpg" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="730" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="By ERIC TUCKER, Associated Press WASHINGTON (AP) — Attorney General Jeff Sessions says he has fired Andrew McCabe, a former FBI deputy director who was a regular target of President Donald Trump&#8217;s anger and criticism, just two days before McCabe&#8217;s scheduled retirement date. McCabe suggested the move was part of the Trump administration&#8217;s &#8220;war on the&hellip;" />
<meta name="twitter:title" content="Trump Lauds Firing Of Ex-Top FBI Official As &#039;Great Day&#039; - KTRS | St Louis News and Talk Radio | The Big 550 AM" />
<meta name="twitter:image" content="http://www.ktrs.com/wp-content/uploads/2018/03/Andrew-McCabe.jpg" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"http:\/\/www.ktrs.com\/","sameAs":[],"@id":"#organization","name":"KTRS | The Big 550 AM","logo":""}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="KTRS | St Louis News and Talk Radio | The Big 550 AM &raquo; Feed" href="http://www.ktrs.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="KTRS | St Louis News and Talk Radio | The Big 550 AM &raquo; Comments Feed" href="http://www.ktrs.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="KTRS | St Louis News and Talk Radio | The Big 550 AM &raquo; Trump Lauds Firing Of Ex-Top FBI Official As &#8216;Great Day&#8217; Comments Feed" href="http://www.ktrs.com/trump-lauds-firing-of-ex-top-fbi-official-as-great-day/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.ktrs.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ch_css_base-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/contesthopper/css/ch_base.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='layerslider-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/LayerSlider/static/layerslider/css/layerslider.css?ver=6.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='livescore-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/personal-livescore/css/style.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='rt-tpg-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/the-post-grid-pro/assets/css/thepostgrid.css?ver=99' type='text/css' media='all' />
<link rel='stylesheet' id='dt-web-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C600%2C700&#038;ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='dt-main-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/themes/dt-the7/css/main.min.css?ver=6.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='dt-awsome-fonts-back-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/themes/dt-the7/fonts/FontAwesome/back-compat.min.css?ver=6.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='dt-awsome-fonts-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/themes/dt-the7/fonts/FontAwesome/css/fontawesome-all.min.css?ver=6.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='dt-fontello-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/themes/dt-the7/fonts/fontello/css/fontello.min.css?ver=6.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='dt-arrow-icons-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/themes/dt-the7/fonts/icomoon-arrows-the7/style.min.css?ver=6.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='dt-custom-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/the7-css/custom.css?ver=8338318f7049' type='text/css' media='all' />
<link rel='stylesheet' id='dt-media-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/the7-css/media.css?ver=8338318f7049' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/themes/dt-the7-child/style.css?ver=6.2.2' type='text/css' media='all' />
<style id='style-inline-css' type='text/css'>
/*----------header---------------*/

a.top_menu{font-size:26px!important; text-decoration:none!important;padding-top:10px;}





/*-----------sidebar form----------------------*/

.sidebar_button { width: 50%; }

.sidebar_email {  width: 80%; }

.foot_style {  background-color: #4996cf;  color: #000;  font-size: 16px; padding: 15px; }

.foot_style > h4 {  border-bottom: 1px solid #fff; color: #000; }



/*---------footer------------*/

.footer .widget-title { font-size: 24px; }

.fa { color: #fff;  font-size: 30px!important;  padding-right: 23px; }

.foot_form {  background-color: #b9d1e2;  color: #fff;  padding: 20px;  text-align: center; font-size: 20px; }

.email_style { width: 60%;  margin: 0 auto; }

.butt_style {  margin: 0 auto;  width: 30%; }

/*---------footer bottom----------*/

.menu-under-footer-menu-container ul li {  display: inline; border-style: none!important; }

.menu-under-footer-menu-container ul li a { font-size:17px; font-weight:bold; }

.menu-under-footer-menu-container {  padding-top: 20px;  margin-right: -44px; }

.footer .widget { margin-bottom:0px; }
</style>
<link rel='stylesheet' id='sccss_style-css'  href='http://www.ktrs.com?sccss=1&#038;ver=4.9.1' type='text/css' media='all' />
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var LS_Meta = {"v":"6.7.1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/LayerSlider/static/layerslider/js/greensock.js?ver=1.19.0'></script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/LayerSlider/static/layerslider/js/layerslider.kreaturamedia.jquery.js?ver=6.7.1'></script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/LayerSlider/static/layerslider/js/layerslider.transitions.js?ver=6.7.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dtLocal = {"themeUrl":"http:\/\/www.ktrs.com\/wp-content\/themes\/dt-the7","passText":"To view this protected post, enter the password below:","moreButtonText":{"loading":"Loading...","loadMore":"Load more"},"postID":"61261","ajaxurl":"http:\/\/www.ktrs.com\/wp-admin\/admin-ajax.php","contactMessages":{"required":"One or more fields have an error. Please check and try again."},"ajaxNonce":"0499175696","pageData":"","themeSettings":{"smoothScroll":"off","lazyLoading":false,"accentColor":{"mode":"solid","color":"#9aabb8"},"desktopHeader":{"height":180},"floatingHeader":{"showAfter":94,"showMenu":false,"height":60,"logo":{"showLogo":true,"html":"","url":"http:\/\/www.ktrs.com\/"}},"mobileHeader":{"firstSwitchPoint":990,"secondSwitchPoint":0,"firstSwitchPointHeight":90,"secondSwitchPointHeight":60},"stickyMobileHeaderFirstSwitch":{"logo":{"html":"<img class=\" preload-me\" src=\"http:\/\/www.ktrs.com\/wp-content\/uploads\/2018\/03\/KTRS-Header_spatday.jpg\" srcset=\"http:\/\/www.ktrs.com\/wp-content\/uploads\/2018\/03\/KTRS-Header_spatday.jpg 1250w\" width=\"1250\" height=\"108\"   sizes=\"1250px\" alt=\"KTRS | St Louis News and Talk Radio | The Big 550 AM\" \/>"}},"stickyMobileHeaderSecondSwitch":{"logo":{"html":"<img class=\" preload-me\" src=\"http:\/\/www.ktrs.com\/wp-content\/uploads\/2018\/03\/KTRS-Header_spatday.jpg\" srcset=\"http:\/\/www.ktrs.com\/wp-content\/uploads\/2018\/03\/KTRS-Header_spatday.jpg 1250w\" width=\"1250\" height=\"108\"   sizes=\"1250px\" alt=\"KTRS | St Louis News and Talk Radio | The Big 550 AM\" \/>"}},"content":{"textColor":"#231f20","headerColor":"#231f20"},"stripes":{"stripe1":{"textColor":"#787d85","headerColor":"#3b3f4a"},"stripe2":{"textColor":"#8b9199","headerColor":"#ffffff"},"stripe3":{"textColor":"#ffffff","headerColor":"#ffffff"}}},"VCMobileScreenWidth":"768"};
var dtShare = {"shareButtonText":{"facebook":"Share on Facebook","twitter":"Tweet","pinterest":"Pin it","linkedin":"Share on Linkedin","whatsapp":"Share on Whatsapp","google":"Share on Google Plus","download":"Download image"},"overlayOpacity":"85"};
/* ]]> */
</script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/themes/dt-the7/js/above-the-fold.min.js?ver=6.2.2'></script>
<meta name="generator" content="Powered by LayerSlider 6.7.1 - Multi-Purpose, Responsive, Parallax, Mobile-Friendly Slider Plugin for WordPress." />
<!-- LayerSlider updates and docs at: https://layerslider.kreaturamedia.com -->
<link rel='https://api.w.org/' href='http://www.ktrs.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.ktrs.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.ktrs.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://www.ktrs.com/?p=61261' />
<link rel="alternate" type="application/json+oembed" href="http://www.ktrs.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ktrs.com%2Ftrump-lauds-firing-of-ex-top-fbi-official-as-great-day%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.ktrs.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ktrs.com%2Ftrump-lauds-firing-of-ex-top-fbi-official-as-great-day%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.11 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-5 { margin:0px 0px 0px 0px;width:100%; max-width:360px; height:100%; max-height:360px; }
	.g-6 { margin:0px 0px 0px 0px;width:100%; max-width:1008px; height:100%; max-height:150px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
.adrotate_widgets, .ajdg_bnnrwidgets, .ajdg_grpwidgets { overflow:hidden; padding:0; }
</style>
<!-- /AdRotate CSS -->


<!-- Google Analytics by Lara - https://www.xtraorbit.com/wordpress-google-analytics-dashboard-widget/ -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-41742785-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-41742785-1');
</script>
	
<script>
	jQuery(document).ready(function() {
        var rel = jQuery(".pl").attr("rel");
		jQuery("#online").load("http://www.ktrs.com/wp-content/plugins/personal-livescore/includes/pl-refresh.php?rel=" + rel);
		var refreshId = setInterval(function() {
			jQuery("#online").load("http://www.ktrs.com/wp-content/plugins/personal-livescore/includes/pl-refresh.php?randval=" + Math.random() + "&rel=" + rel);
		}, 600000);
	});
	</script>    <script type="text/javascript">
        if (typeof ajaxurl === "undefined") 
        var ajaxurl = 'http://www.ktrs.com/wp-admin/admin-ajax.php';
    </script>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]-->
<!-- BEGIN GADWP v5.3.1.1 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-41742785-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/
#comments{display:none;}		</style>
	<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><meta property="og:image" content="http://www.ktrs.com/wp-content/uploads/2017/12/KTRS_Square_Logo.jpg"/></head>
<body class="post-template-default single single-post postid-61261 single-format-image disabled-hover-icons dt-responsive-on srcset-enabled btn-flat custom-btn-color custom-btn-hover-color bold-icons floating-mobile-menu-icon top-header first-switch-logo-left first-switch-menu-right second-switch-logo-left second-switch-menu-right right-mobile-menu layzr-loading-on popup-message-style dt-fa-compatibility the7-ver-6.2.2 wpb-js-composer js-comp-ver-5.4.5 vc_responsive">
<!-- The7 6.2.2 -->

<div id="page">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

<div class="masthead classic-header center bg-behind-menu logo-center widgets full-height small-mobile-menu-icon mobile-menu-icon-bg-on dt-parent-menu-clickable show-mobile-logo" role="banner">

			<div class="top-bar">
			<div class="left-widgets mini-widgets"><div class="text-area show-on-desktop in-top-bar-left in-menu-second-switch"><p><a href="/ktrs-streaming/" class="top_menu">LISTEN LIVE NOW!</a></p>
</div></div>			<div class="right-widgets mini-widgets"><div class="soc-ico show-on-desktop in-top-bar-right in-menu-second-switch custom-bg disabled-border border-off hover-accent-bg hover-disabled-border  hover-border-off"><a title="Twitter" href="https://twitter.com/550KTRS" target="_blank" class="twitter"><span class="soc-font-icon"></span><span class="screen-reader-text">Twitter</span></a><a title="Facebook" href="https://www.facebook.com/550ktrs" target="_blank" class="facebook"><span class="soc-font-icon"></span><span class="screen-reader-text">Facebook</span></a><a title="Instagram" href="https://www.instagram.com/550ktrs/" target="_blank" class="instagram"><span class="soc-font-icon"></span><span class="screen-reader-text">Instagram</span></a><a title="SoundCloud" href="https://soundcloud.com/user-423077123" target="_blank" class="soundcloud"><span class="soc-font-icon"></span><span class="screen-reader-text">SoundCloud</span></a></div></div>		</div>

	<header class="header-bar">

						<div class="branding">
					<div id="site-title" class="assistive-text">KTRS | St Louis News and Talk Radio | The Big 550 AM</div>
					<div id="site-description" class="assistive-text">Your SUPER-powered St Louis Radio Station</div>
					<a href="http://www.ktrs.com/"><img class=" preload-me" src="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2018/03/KTRS-Header_spatday.jpg" srcset="http://www.ktrs.com/wp-content/uploads/2018/03/KTRS-Header_spatday.jpg 1250w" width="1250" height="108"   sizes="1250px" alt="KTRS | St Louis News and Talk Radio | The Big 550 AM" /><img class="mobile-logo preload-me" src="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2018/03/KTRS-Header_spatday.jpg" srcset="http://www.ktrs.com/wp-content/uploads/2018/03/KTRS-Header_spatday.jpg 1250w" width="1250" height="108"   sizes="1250px" alt="KTRS | St Louis News and Talk Radio | The Big 550 AM" /></a>
					

					<div class="mini-widgets"></div>
					<div class="mini-widgets"></div>
				</div>
		<nav class="navigation">

			<ul id="primary-menu" class="main-nav underline-decoration l-to-r-line outside-item-remove-margin" role="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-57426 first has-children"><a href='http://www.ktrs.com/' data-level='1'><span class="menu-item-text"><span class="menu-text">Home</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57432 first"><a href='http://www.ktrs.com/about-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">About KTRS</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-57430 has-children"><a href='http://www.ktrs.com/shows/' data-level='1'><span class="menu-item-text"><span class="menu-text">Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49194 first has-children"><a href='http://www.ktrs.com/weekday-shows/' data-level='2'><span class="menu-item-text"><span class="menu-text">Weekday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58131 first"><a href='http://www.ktrs.com/weekday-shows/the-jim-bohannon-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Jim Bohannon Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58130"><a href='http://www.ktrs.com/first-light/' data-level='3'><span class="menu-item-text"><span class="menu-text">First Light</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58132"><a href='http://www.ktrs.com/farmer-dave/' data-level='3'><span class="menu-item-text"><span class="menu-text">Farmer Dave</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49199 has-children"><a href='http://www.ktrs.com/mcgraw-milhaven/' data-level='3'><span class="menu-item-text"><span class="menu-text">McGraw Milhaven</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60628 first"><a href='http://www.ktrs.com/food-bloggers/' data-level='4'><span class="menu-item-text"><span class="menu-text">Food Bloggers</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49200"><a href='http://www.ktrs.com/the-inside/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Inside</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49201"><a href='http://www.ktrs.com/john-carney/' data-level='3'><span class="menu-item-text"><span class="menu-text">John Carney</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60663 has-children"><a href='http://www.ktrs.com/guy-phillips/' data-level='3'><span class="menu-item-text"><span class="menu-text">Guy Phillips</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61149 first"><a href='http://www.ktrs.com/basketball-square/' data-level='4'><span class="menu-item-text"><span class="menu-text">Basketball Square</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49204"><a href='http://www.ktrs.com/the-big-sports-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Big Sports Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49207"><a href='http://www.ktrs.com/all-access-with-jay-kanzler/' data-level='3'><span class="menu-item-text"><span class="menu-text">All Access With Jay Kanzler</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49211 has-children"><a href='http://www.ktrs.com/saturday-shows/' data-level='2'><span class="menu-item-text"><span class="menu-text">Saturday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49212 first"><a href='http://www.ktrs.com/saturday-morning-wake-up/' data-level='3'><span class="menu-item-text"><span class="menu-text">Saturday Morning Wake Up</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49213"><a href='http://www.ktrs.com/550-yard-sale/' data-level='3'><span class="menu-item-text"><span class="menu-text">Walter Knoll Florist 550 Yard Sale</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49214"><a href='http://www.ktrs.com/purinas-animal-advice/' data-level='3'><span class="menu-item-text"><span class="menu-text">Purina&#8217;s Animal Advice</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49215"><a href='http://www.ktrs.com/straight-talk-on-retirement/' data-level='3'><span class="menu-item-text"><span class="menu-text">Straight Talk on Retirement</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49216"><a href='http://www.ktrs.com/inside-out/' data-level='3'><span class="menu-item-text"><span class="menu-text">Inside Out</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60831"><a href='http://www.ktrs.com/when-retirement-happens/' data-level='3'><span class="menu-item-text"><span class="menu-text">When Retirement Happens</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58125"><a href='http://www.ktrs.com/max-on-movies-2/' data-level='3'><span class="menu-item-text"><span class="menu-text">Max On Movies</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58126"><a href='http://www.ktrs.com/thanks-for-the-memories/' data-level='3'><span class="menu-item-text"><span class="menu-text">Thanks for the Memories</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49222 has-children"><a href='http://www.ktrs.com/sunday-shows/' data-level='2'><span class="menu-item-text"><span class="menu-text">Sunday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49223 first"><a href='http://www.ktrs.com/having-a-senior-moment/' data-level='3'><span class="menu-item-text"><span class="menu-text">We&#8217;re Having a Senior Moment</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49225"><a href='http://www.ktrs.com/money-talk/' data-level='3'><span class="menu-item-text"><span class="menu-text">Money Talk</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49224"><a href='http://www.ktrs.com/mortgages-and-more/' data-level='3'><span class="menu-item-text"><span class="menu-text">Mortgages And More</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49229"><a href='http://www.ktrs.com/fairways-and-greens/' data-level='3'><span class="menu-item-text"><span class="menu-text">Fairways and Greens</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58128"><a href='http://www.ktrs.com/the-big-sports-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Big Sports Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49228"><a href='http://www.ktrs.com/this-week-in-real-estate/' data-level='3'><span class="menu-item-text"><span class="menu-text">This Week In Real Estate</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58886"><a href='http://www.ktrs.com/investing-for-life-radio/' data-level='3'><span class="menu-item-text"><span class="menu-text">Investing for Life Radio</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49232"><a href='http://www.ktrs.com/the-budweiser-big-bbq-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Budweiser Big BBQ Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49233"><a href='http://www.ktrs.com/outdoors-dan/' data-level='3'><span class="menu-item-text"><span class="menu-text">Outdoors Dan</span></span></a></li> </ul></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49235 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">NEWS</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49236 first"><a href='http://www.ktrs.com/local/' data-level='2'><span class="menu-item-text"><span class="menu-text">Local News</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49237"><a href='http://www.ktrs.com/national/' data-level='2'><span class="menu-item-text"><span class="menu-text">National News</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59912"><a href='http://www.ktrs.com/news-staff/' data-level='2'><span class="menu-item-text"><span class="menu-text">News Staff</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57700"><a href='http://www.ktrs.com/gone-viral/' data-level='2'><span class="menu-item-text"><span class="menu-text">Gone Viral</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49264 has-children"><a href='http://www.ktrs.com/sports/' data-level='1'><span class="menu-item-text"><span class="menu-text">Sports</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60876 first"><a href='http://www.mvc-sports.com/sports/2017/8/16/2018_ArchMadness_TourneyCentral.aspx' data-level='2'><span class="menu-item-text"><span class="menu-text">Arch Madness</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60888"><a href='http://mutigers.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Mizzou</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60889"><a href='http://www.slubillikens.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Saint Louis Billikens</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60890"><a href='http://mvc-sports.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Missouri Valley Conference</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60891"><a href='https://www.mlb.com/cardinals' data-level='2'><span class="menu-item-text"><span class="menu-text">St. Louis Cardinals</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60892"><a href='https://www.nhl.com/blues' data-level='2'><span class="menu-item-text"><span class="menu-text">St. Louis Blues</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58172"><a href='http://www.ktrs.com/high-school-sports/' data-level='2'><span class="menu-item-text"><span class="menu-text">High School Sports</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49245 has-children"><a href='http://www.ktrs.com/events/' data-level='1'><span class="menu-item-text"><span class="menu-text">Events</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49246 first"><a href='http://www.ktrs.com/contests/' data-level='2'><span class="menu-item-text"><span class="menu-text">Contests Details</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61085"><a href='http://www.ktrs.com/at-the-rep/' data-level='2'><span class="menu-item-text"><span class="menu-text">At The Rep</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49247 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">Connect</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49248 first"><a href='http://www.ktrs.com/contact-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">Contact</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49250"><a href='http://www.ktrs.com/ktrs-the-big-550-newsletter-2016/' data-level='2'><span class="menu-item-text"><span class="menu-text">Newsletter</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49251 has-children"><a href='http://www.ktrs.com/ktrs-cares/' data-level='2'><span class="menu-item-text"><span class="menu-text">KTRS Cares</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60893 first"><a href='http://www.saintlouisfc.com/' data-level='3'><span class="menu-item-text"><span class="menu-text">Saint Louis FC</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49252"><a href='http://www.ktrs.com/advertise-on-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">Advertise On KTRS</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57717"><a href='http://www.ktrs.com/ktrs-streaming/' data-level='1'><span class="menu-item-text"><span class="menu-text">LISTEN NOW</span></span></a></li> </ul>
			<div class="mini-widgets"><div class="mini-search show-on-desktop in-menu-first-switch in-menu-second-switch">	<form class="searchform" role="search" method="get" action="http://www.ktrs.com/">

	<label for="search" class="screen-reader-text">Search:</label>
		<input type="text" class="field searchform-s" name="s" value="" placeholder="Type and hit enter &hellip;" />
				<input type="submit" class="assistive-text searchsubmit" value="Go!" />
		<a href="#go" id="trigger-overlay" class="submit mini-icon-off">&nbsp;</a>
	</form></div></div>
		</nav>

	</header>

</div><div class='dt-close-mobile-menu-icon'><span></span></div>
<div class='dt-mobile-header'>
	<ul id="mobile-menu" class="mobile-main-nav" role="menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-57426 first has-children"><a href='http://www.ktrs.com/' data-level='1'><span class="menu-item-text"><span class="menu-text">Home</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57432 first"><a href='http://www.ktrs.com/about-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">About KTRS</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-57430 has-children"><a href='http://www.ktrs.com/shows/' data-level='1'><span class="menu-item-text"><span class="menu-text">Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49194 first has-children"><a href='http://www.ktrs.com/weekday-shows/' data-level='2'><span class="menu-item-text"><span class="menu-text">Weekday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58131 first"><a href='http://www.ktrs.com/weekday-shows/the-jim-bohannon-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Jim Bohannon Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58130"><a href='http://www.ktrs.com/first-light/' data-level='3'><span class="menu-item-text"><span class="menu-text">First Light</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58132"><a href='http://www.ktrs.com/farmer-dave/' data-level='3'><span class="menu-item-text"><span class="menu-text">Farmer Dave</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49199 has-children"><a href='http://www.ktrs.com/mcgraw-milhaven/' data-level='3'><span class="menu-item-text"><span class="menu-text">McGraw Milhaven</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60628 first"><a href='http://www.ktrs.com/food-bloggers/' data-level='4'><span class="menu-item-text"><span class="menu-text">Food Bloggers</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49200"><a href='http://www.ktrs.com/the-inside/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Inside</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49201"><a href='http://www.ktrs.com/john-carney/' data-level='3'><span class="menu-item-text"><span class="menu-text">John Carney</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60663 has-children"><a href='http://www.ktrs.com/guy-phillips/' data-level='3'><span class="menu-item-text"><span class="menu-text">Guy Phillips</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61149 first"><a href='http://www.ktrs.com/basketball-square/' data-level='4'><span class="menu-item-text"><span class="menu-text">Basketball Square</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49204"><a href='http://www.ktrs.com/the-big-sports-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Big Sports Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49207"><a href='http://www.ktrs.com/all-access-with-jay-kanzler/' data-level='3'><span class="menu-item-text"><span class="menu-text">All Access With Jay Kanzler</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49211 has-children"><a href='http://www.ktrs.com/saturday-shows/' data-level='2'><span class="menu-item-text"><span class="menu-text">Saturday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49212 first"><a href='http://www.ktrs.com/saturday-morning-wake-up/' data-level='3'><span class="menu-item-text"><span class="menu-text">Saturday Morning Wake Up</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49213"><a href='http://www.ktrs.com/550-yard-sale/' data-level='3'><span class="menu-item-text"><span class="menu-text">Walter Knoll Florist 550 Yard Sale</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49214"><a href='http://www.ktrs.com/purinas-animal-advice/' data-level='3'><span class="menu-item-text"><span class="menu-text">Purina&#8217;s Animal Advice</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49215"><a href='http://www.ktrs.com/straight-talk-on-retirement/' data-level='3'><span class="menu-item-text"><span class="menu-text">Straight Talk on Retirement</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49216"><a href='http://www.ktrs.com/inside-out/' data-level='3'><span class="menu-item-text"><span class="menu-text">Inside Out</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60831"><a href='http://www.ktrs.com/when-retirement-happens/' data-level='3'><span class="menu-item-text"><span class="menu-text">When Retirement Happens</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58125"><a href='http://www.ktrs.com/max-on-movies-2/' data-level='3'><span class="menu-item-text"><span class="menu-text">Max On Movies</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58126"><a href='http://www.ktrs.com/thanks-for-the-memories/' data-level='3'><span class="menu-item-text"><span class="menu-text">Thanks for the Memories</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49222 has-children"><a href='http://www.ktrs.com/sunday-shows/' data-level='2'><span class="menu-item-text"><span class="menu-text">Sunday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49223 first"><a href='http://www.ktrs.com/having-a-senior-moment/' data-level='3'><span class="menu-item-text"><span class="menu-text">We&#8217;re Having a Senior Moment</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49225"><a href='http://www.ktrs.com/money-talk/' data-level='3'><span class="menu-item-text"><span class="menu-text">Money Talk</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49224"><a href='http://www.ktrs.com/mortgages-and-more/' data-level='3'><span class="menu-item-text"><span class="menu-text">Mortgages And More</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49229"><a href='http://www.ktrs.com/fairways-and-greens/' data-level='3'><span class="menu-item-text"><span class="menu-text">Fairways and Greens</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58128"><a href='http://www.ktrs.com/the-big-sports-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Big Sports Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49228"><a href='http://www.ktrs.com/this-week-in-real-estate/' data-level='3'><span class="menu-item-text"><span class="menu-text">This Week In Real Estate</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58886"><a href='http://www.ktrs.com/investing-for-life-radio/' data-level='3'><span class="menu-item-text"><span class="menu-text">Investing for Life Radio</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49232"><a href='http://www.ktrs.com/the-budweiser-big-bbq-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Budweiser Big BBQ Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49233"><a href='http://www.ktrs.com/outdoors-dan/' data-level='3'><span class="menu-item-text"><span class="menu-text">Outdoors Dan</span></span></a></li> </ul></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49235 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">NEWS</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49236 first"><a href='http://www.ktrs.com/local/' data-level='2'><span class="menu-item-text"><span class="menu-text">Local News</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49237"><a href='http://www.ktrs.com/national/' data-level='2'><span class="menu-item-text"><span class="menu-text">National News</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59912"><a href='http://www.ktrs.com/news-staff/' data-level='2'><span class="menu-item-text"><span class="menu-text">News Staff</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57700"><a href='http://www.ktrs.com/gone-viral/' data-level='2'><span class="menu-item-text"><span class="menu-text">Gone Viral</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49264 has-children"><a href='http://www.ktrs.com/sports/' data-level='1'><span class="menu-item-text"><span class="menu-text">Sports</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60876 first"><a href='http://www.mvc-sports.com/sports/2017/8/16/2018_ArchMadness_TourneyCentral.aspx' data-level='2'><span class="menu-item-text"><span class="menu-text">Arch Madness</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60888"><a href='http://mutigers.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Mizzou</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60889"><a href='http://www.slubillikens.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Saint Louis Billikens</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60890"><a href='http://mvc-sports.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Missouri Valley Conference</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60891"><a href='https://www.mlb.com/cardinals' data-level='2'><span class="menu-item-text"><span class="menu-text">St. Louis Cardinals</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60892"><a href='https://www.nhl.com/blues' data-level='2'><span class="menu-item-text"><span class="menu-text">St. Louis Blues</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58172"><a href='http://www.ktrs.com/high-school-sports/' data-level='2'><span class="menu-item-text"><span class="menu-text">High School Sports</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49245 has-children"><a href='http://www.ktrs.com/events/' data-level='1'><span class="menu-item-text"><span class="menu-text">Events</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49246 first"><a href='http://www.ktrs.com/contests/' data-level='2'><span class="menu-item-text"><span class="menu-text">Contests Details</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61085"><a href='http://www.ktrs.com/at-the-rep/' data-level='2'><span class="menu-item-text"><span class="menu-text">At The Rep</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49247 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">Connect</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49248 first"><a href='http://www.ktrs.com/contact-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">Contact</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49250"><a href='http://www.ktrs.com/ktrs-the-big-550-newsletter-2016/' data-level='2'><span class="menu-item-text"><span class="menu-text">Newsletter</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49251 has-children"><a href='http://www.ktrs.com/ktrs-cares/' data-level='2'><span class="menu-item-text"><span class="menu-text">KTRS Cares</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60893 first"><a href='http://www.saintlouisfc.com/' data-level='3'><span class="menu-item-text"><span class="menu-text">Saint Louis FC</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49252"><a href='http://www.ktrs.com/advertise-on-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">Advertise On KTRS</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57717"><a href='http://www.ktrs.com/ktrs-streaming/' data-level='1'><span class="menu-item-text"><span class="menu-text">LISTEN NOW</span></span></a></li> 	</ul>
	<div class='mobile-mini-widgets-in-menu'></div>
</div>

	


<div id="main" class="sidebar-right sidebar-divider-off"  >

	
    <div class="main-gradient"></div>
    <div class="wf-wrap">
    <div class="wf-container-main">

	

	
		
		<div id="content" class="content" role="main">

			
				
<article id="post-61261" class="post-61261 post type-post status-publish format-image has-post-thumbnail category-home-national category-home-slider-feature category-national tag-andrew-mccabe tag-fbi tag-jeff-sessions tag-president-trump post_format-post-format-image format-photo category-15105 category-191 category-2 post_format-280 description-off">

	<div class="post-thumbnail"><img class="lazy-load preload-me" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%201024%20512&#39;%2F%3E" data-src="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2018/03/Andrew-McCabe-1024x512.jpg" data-srcset="http://www.ktrs.com/wp-content/uploads/2018/03/Andrew-McCabe-1024x512.jpg 1024w" width="1024" height="512"  title="Andrew McCabe" alt="" /></div><div class="entry-content"><p>By ERIC TUCKER, Associated Press</p>
<p>WASHINGTON (AP) — Attorney General Jeff Sessions says he has fired Andrew McCabe, a former FBI deputy director who was a regular target of President Donald Trump&#8217;s anger and criticism, just two days before McCabe&#8217;s scheduled retirement date. McCabe suggested the move was part of the Trump administration&#8217;s &#8220;war on the FBI.&#8221;</p>
<p>The dismissal Friday was made on the recommendation of FBI disciplinary officials. An upcoming inspector general&#8217;s report is expected to conclude that McCabe authorized the release of information to the media and was not forthcoming with the watchdog office as it examined the bureau&#8217;s handling of the Hillary Clinton email investigation.</p>
<p>&#8220;The FBI expects every employee to adhere to the highest standards of honesty, integrity, and accountability,&#8221; Sessions said in a statement.<br />
McCabe said his credibility had been attacked as &#8220;part of a larger effort not just to slander me personally&#8221; but also the FBI and law enforcement.</p>
<p>&#8220;It is part of this administration&#8217;s ongoing war on the FBI and the efforts of the special counsel investigation, which continue to this day,&#8221; he added, referring to Robert Mueller&#8217;s probe into potential coordination between Russia and the Trump campaign. &#8220;Their persistence in this campaign only highlights the importance of the special counsel&#8217;s work.&#8221;</p>
<p>McCabe asserted he was singled out because of the &#8220;role I played, the actions I took, and the events I witnessed in the aftermath of the firing of James Comey,&#8221; whom Trump fired as FBI director last May.</p>
<p>Mueller is investigating whether Trump&#8217;s actions, including Comey&#8217;s ouster, constitute obstruction of justice. McCabe, a Comey confidant, could be an important witness.</p>
<p>McCabe said the release of the findings against him was accelerated after he told congressional officials that he could corroborate Comey&#8217;s accounts of Comey&#8217;s conversations with the president.</p>
<p>McCabe spent more than 20 years as a career FBI official and played key roles in some of the bureau&#8217;s most recent significant investigations. Trump repeatedly condemned him over the past year as emblematic of an FBI leadership he contends is biased against his administration.</p>
<p>In a tweet early Saturday, Trump said it was &#8220;a great day for Democracy&#8221; and &#8220;a great day for the hard working men and women of the FBI.&#8221; He asserted without elaboration that McCabe &#8220;knew all about the lies and corruption going on at the highest levels of the FBI.&#8221;</p>
<p>McCabe had been on leave from the FBI since January, when he abruptly left the deputy director position. He had planned to retire on Sunday, and the dismissal probably jeopardizes his ability to collect his full pension benefits. His removal could add to the turmoil that has enveloped the FBI since Comey&#8217;s firing and as the FBI continues its Trump campaign investigation that the White House has dismissed as a hoax.</p>
<p>The firing arises from an inspector general review into how the FBI handled the Clinton email investigation. That inquiry focused not only on specific decisions made by FBI leadership but also on news media leaks.</p>
<p>McCabe came under scrutiny over an October 2016 news report that revealed differing approaches within the FBI and Justice Department over how aggressively the Clinton Foundation should be investigated. The watchdog office has concluded that McCabe authorized FBI officials to speak to a Wall Street Journal reporter for that story and that McCabe had not been forthcoming with investigators. McCabe denies it.</p>
<p>In his statement, McCabe said he had the authority to share information with journalists through the public affairs office, a practice he said was common and continued under the current FBI director, Christopher Wray. McCabe said he honestly answered questions about whom he had spoken to and when, and that when he thought his answers were misunderstood, he contacted investigators to correct them.</p>
<p>The media outreach came at a time when McCabe said he was facing public accusations of partisanship and followed reports that his wife, during a run for the state Senate in Virginia, had received campaign contributions from a Clinton ally. McCabe suggested in his statement that he was trying to &#8220;set the record straight&#8221; about the FBI&#8217;s independence against the background of those allegations.</p>
<p>Despite his defense, officials at the FBI&#8217;s Office of Professional Responsibility recommended the firing, leaving Justice Department leaders in a difficult situation. Sessions, whose job status has for months appeared shaky under his own blistering criticism from Trump, risked inflaming the White House if he decided against firing McCabe. But a decision to dismiss McCabe days before his retirement nonetheless carried the risk of angering his rank-and-file supporters at the FBI.</p>
<p>McCabe enjoyed a rapid career ascent in the bureau after joining in 1996. Before being named FBI deputy director last year, he led the bureau&#8217;s national security branch and also the Washington field office, one of the its largest.</p>
<p>But he became entangled in presidential politics in 2016 when it was revealed that his wife, during her unsuccessful legislative run, received campaign contributions from the political action committee of then-Virginia Gov. Terry McAuliffe, a longtime Clinton friend. The FBI has said McCabe received the necessary ethics approval about his wife&#8217;s candidacy and was not supervising the Clinton investigation at the time.</p>
<p>He became acting director following the firing last May of Comey, and immediately assumed direct oversight of the FBI&#8217;s investigation into the Trump campaign.</p>
<p>He quickly found himself at odds with the Trump administration.</p>
<p>As a congressional hearing days after Comey&#8217;s dismissal, McCabe contradicted White House assertions that the Trump campaign investigation was one of the &#8220;smallest things&#8221; on the FBI&#8217;s plate. He also strongly disputed the administration&#8217;s suggestion that Comey had lost the support of the bureau&#8217;s workforce.</p>
<p>&#8220;I can tell you that the majority, the vast majority of FBI employees, enjoyed a deep and positive connection to Director Comey,&#8221; McCabe said.<br />
___<br />
Follow Eric Tucker on Twitter at http://www.twitter.com/etuckerAP</p>
</div><div class="single-related-posts"><h3>Related Posts</h3><section class="items-grid"><div class=" related-item"><article class="post-format-photo"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="http://www.ktrs.com/flood-damage-assessments-start-monday-in-three-illinois-counties/" ><img class="lazy-load preload-me" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2018/03/FEMA-logo-110x80.jpg" data-srcset="http://www.ktrs.com/wp-content/uploads/2018/03/FEMA-logo-110x80.jpg 110w, http://www.ktrs.com/wp-content/uploads/2018/03/FEMA-logo-220x160.jpg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="http://www.ktrs.com/flood-damage-assessments-start-monday-in-three-illinois-counties/">Flood Damage Assessments Start Monday In Three Illinois Counties</a><br /><time class="text-secondary" datetime="2018-03-17T08:58:54+00:00">March 17, 2018</time></div></article></div><div class=" related-item"><article class="post-format-photo"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="http://www.ktrs.com/man-jailed-in-shooting-at-chesterfield-couples-home-charged-with-sexual-assault-of-wife/" ><img class="lazy-load preload-me" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2018/03/DXoS0jtUQAAm5XD-110x80.jpg" data-srcset="http://www.ktrs.com/wp-content/uploads/2018/03/DXoS0jtUQAAm5XD-110x80.jpg 110w, http://www.ktrs.com/wp-content/uploads/2018/03/DXoS0jtUQAAm5XD-220x160.jpg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="http://www.ktrs.com/man-jailed-in-shooting-at-chesterfield-couples-home-charged-with-sexual-assault-of-wife/">Man Jailed in Shooting at Chesterfield Couple&#8217;s Home Charged with Sexual Assault of Wife</a><br /><time class="text-secondary" datetime="2018-03-16T17:57:10+00:00">March 16, 2018</time></div></article></div><div class=" related-item"><article class="post-format-photo"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="http://www.ktrs.com/company-says-it-gave-correct-address-before-officers-death/" ><img class="lazy-load preload-me" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2018/03/Officer-Christopher-Ryan-Morton-110x80.jpg" data-srcset="http://www.ktrs.com/wp-content/uploads/2018/03/Officer-Christopher-Ryan-Morton-110x80.jpg 110w, http://www.ktrs.com/wp-content/uploads/2018/03/Officer-Christopher-Ryan-Morton-220x160.jpg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="http://www.ktrs.com/company-says-it-gave-correct-address-before-officers-death/">Company Says It Gave Correct Address Before Officer&#8217;s Death</a><br /><time class="text-secondary" datetime="2018-03-16T17:06:18+00:00">March 16, 2018</time></div></article></div><div class=" related-item"><article class="post-format-photo"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="http://www.ktrs.com/fire-warnings-issued-for-six-states-in-nations-midsection/" ><img class="lazy-load preload-me" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2014/06/Fire-generic-no-words.jpg" data-srcset="http://www.ktrs.com/wp-content/uploads/2014/06/Fire-generic-no-words.jpg 110w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="http://www.ktrs.com/fire-warnings-issued-for-six-states-in-nations-midsection/">Fire Warnings Issued For Six States In Nation&#8217;s Midsection</a><br /><time class="text-secondary" datetime="2018-03-16T17:00:28+00:00">March 16, 2018</time></div></article></div><div class=" related-item"><article class="post-format-photo"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="http://www.ktrs.com/bridge-collapse-puts-spotlight-on-rapid-building-technique/" ><img class="lazy-load preload-me" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2018/03/Florida-Bridge-Collapse-1-110x80.jpg" data-srcset="http://www.ktrs.com/wp-content/uploads/2018/03/Florida-Bridge-Collapse-1-110x80.jpg 110w, http://www.ktrs.com/wp-content/uploads/2018/03/Florida-Bridge-Collapse-1-220x160.jpg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="http://www.ktrs.com/bridge-collapse-puts-spotlight-on-rapid-building-technique/">Bridge Collapse Puts Spotlight On Rapid Building Technique</a><br /><time class="text-secondary" datetime="2018-03-16T16:52:45+00:00">March 16, 2018</time></div></article></div><div class=" related-item"><article class="post-format-photo"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="http://www.ktrs.com/local-disability-advocate-critical-of-stephen-hawking-media-coverage/" ><img class="lazy-load preload-me" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2018/03/stephen-hawking-110x80.jpeg" data-srcset="http://www.ktrs.com/wp-content/uploads/2018/03/stephen-hawking-110x80.jpeg 110w, http://www.ktrs.com/wp-content/uploads/2018/03/stephen-hawking-220x160.jpeg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="http://www.ktrs.com/local-disability-advocate-critical-of-stephen-hawking-media-coverage/">Local Disability Advocate Critical of Stephen Hawking Media Coverage</a><br /><time class="text-secondary" datetime="2018-03-16T15:35:14+00:00">March 16, 2018</time></div></article></div></section></div>
</article>
			
			
	<div id="comments" class="comments-area">
	
	
		
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/trump-lauds-firing-of-ex-top-fbi-official-as-great-day/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in text-small">You must be <a href="http://www.ktrs.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.ktrs.com%2Ftrump-lauds-firing-of-ex-top-fbi-official-as-great-day%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
	</div><!-- #comments .comments-area -->

		</div><!-- #content -->

		
    <aside id="sidebar" class="sidebar solid-bg">
        <div class="sidebar-content widget-divider-off">
			<section id="text-129" class="widget widget_text">			<div class="textwidget"></div>
		</section>        </div>
    </aside><!-- #sidebar -->


	


			</div><!-- .wf-container -->
		</div><!-- .wf-wrap -->
	</div><!-- #main -->
    
    
    <div class="footer_q_l footer">
		<div class="inner wf-wrap">

			<div class="col_g_4"><div class="widget-title">Weekday Shows</div><div class="menu-footer-menu-column1-container"><ul id="menu-footer-menu-column1" class="menu"><li id="menu-item-57484" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57484"><a href="http://www.ktrs.com/weekday-shows/the-jim-bohannon-show/">The Jim Bohannon Show</a></li>
<li id="menu-item-57485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57485"><a href="http://www.ktrs.com/first-light/">First Light</a></li>
<li id="menu-item-57486" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57486"><a href="http://www.ktrs.com/farmer-dave/">Farmer Dave</a></li>
<li id="menu-item-57487" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57487"><a href="http://www.ktrs.com/mcgraw-milhaven/">McGraw Milhaven</a></li>
<li id="menu-item-57488" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57488"><a href="http://www.ktrs.com/the-inside/">The Inside</a></li>
<li id="menu-item-57489" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57489"><a href="http://www.ktrs.com/john-carney/">John Carney</a></li>
<li id="menu-item-58320" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58320"><a href="http://www.ktrs.com/pm-drive/">PM Drive</a></li>
<li id="menu-item-57491" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57491"><a href="http://www.ktrs.com/fox-2-news/">FOX 2 News</a></li>
<li id="menu-item-57492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57492"><a href="http://www.ktrs.com/the-big-sports-show/">The Big Sports Show</a></li>
<li id="menu-item-57493" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57493"><a href="http://www.ktrs.com/sports-medicine-2/">Sports Medicine</a></li>
<li id="menu-item-57494" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57494"><a href="http://www.ktrs.com/all-access-with-jay-kanzler/">All Access With Jay Kanzler</a></li>
<li id="menu-item-57495" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57495"><a href="http://www.ktrs.com/ktrs-news-staff/">KTRS News Staff</a></li>
<li id="menu-item-57496" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57496"><a href="http://www.ktrs.com/paul-harris/">Paul Harris</a></li>
<li id="menu-item-57497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57497"><a href="http://www.ktrs.com/doug-mcelvein/">Doug McElvein</a></li>
</ul></div></div>
			<div class="col_g_4"><div class="widget-title">Saturday Shows</div><div class="menu-footer-menu-column2-container"><ul id="menu-footer-menu-column2" class="menu"><li id="menu-item-57558" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57558"><a href="http://www.ktrs.com/saturday-morning-wake-up/">Saturday Morning Wake Up</a></li>
<li id="menu-item-57559" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57559"><a href="http://www.ktrs.com/550-yard-sale/">Walter Knoll Florist 550 Yard Sale</a></li>
<li id="menu-item-57560" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57560"><a href="http://www.ktrs.com/purinas-animal-advice/">Purina’s Animal Advice</a></li>
<li id="menu-item-57561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57561"><a href="http://www.ktrs.com/straight-talk-on-retirement/">Straight Talk on Retirement</a></li>
<li id="menu-item-57562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57562"><a href="http://www.ktrs.com/inside-out/">Inside Out</a></li>
<li id="menu-item-57563" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57563"><a href="http://www.ktrs.com/when-retirement-happens/">America’s Wealth Management</a></li>
<li id="menu-item-57564" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57564"><a href="http://www.ktrs.com/retire-worry-free/">Retire Worry Free</a></li>
<li id="menu-item-57565" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57565"><a href="http://www.ktrs.com/growing-green-st-louis/">Growing Green St. Louis</a></li>
</ul></div></div>
			<div class="col_g_4"><div class="widget-title">Sunday Shows</div><div class="menu-footer-menu-column3-container"><ul id="menu-footer-menu-column3" class="menu"><li id="menu-item-57657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57657"><a href="http://www.ktrs.com/having-a-senior-moment/">We’re Having a Senior Moment</a></li>
<li id="menu-item-57658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57658"><a href="http://www.ktrs.com/money-talk/">Money Talk</a></li>
<li id="menu-item-57659" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57659"><a href="http://www.ktrs.com/mortgages-and-more/">Mortgages And More</a></li>
<li id="menu-item-57661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57661"><a href="http://www.ktrs.com/when-retirement-happens/">America’s Wealth Management</a></li>
<li id="menu-item-57662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57662"><a href="http://www.ktrs.com/this-week-in-real-estate/">This Week In Real Estate</a></li>
<li id="menu-item-57663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57663"><a href="http://www.ktrs.com/fairways-and-greens/">Fairways and Greens</a></li>
<li id="menu-item-57665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57665"><a href="http://www.ktrs.com/freedom-investing-lifestyle/">Freedom Investing Lifestyle</a></li>
<li id="menu-item-57666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57666"><a href="http://www.ktrs.com/the-budweiser-big-bbq-show/">The Budweiser Big BBQ Show</a></li>
<li id="menu-item-57667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57667"><a href="http://www.ktrs.com/outdoors-dan/">Outdoors Dan</a></li>
<li id="menu-item-57668" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57668"><a href="http://www.ktrs.com/nothing-really-good-happens-after-midnight/">Nothing Really Good Happens After Midnight</a></li>
</ul></div></div>
			<div class="col_g_4 last"><div class="widget-title">News</div><div class="menu-footer-menu-column4-container"><ul id="menu-footer-menu-column4" class="menu"><li id="menu-item-57671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57671"><a href="http://www.ktrs.com/local/">Local</a></li>
<li id="menu-item-57672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57672"><a href="http://www.ktrs.com/national/">National</a></li>
</ul></div><div class="sec"><div class="widget-title">Sports</div><div class="menu-footer-menu-column4-sports-container"><ul id="menu-footer-menu-column4-sports" class="menu"><li id="menu-item-57674" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57674"><a href="http://www.ktrs.com/saint-louis-fc/">Saint Louis FC</a></li>
<li id="menu-item-57675" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57675"><a href="http://www.ktrs.com/category/sports/st-louis-university-billikens/">SLU Billikens</a></li>
<li id="menu-item-57676" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57676"><a href="http://www.ktrs.com/category/sports/st-louis-blues-hockey/">St Louis Blues Hockey</a></li>
<li id="menu-item-57677" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57677"><a href="http://www.ktrs.com/mizzou-tigers/">Mizzou Tigers</a></li>
</ul></div></div><div class="third"><div class="widget-title">Connects</div><div class="menu-footer-menu-column5-container"><ul id="menu-footer-menu-column5" class="menu"><li id="menu-item-57678" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57678"><a href="http://www.ktrs.com/contact-ktrs/">Contact KTRS</a></li>
<li id="menu-item-57680" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57680"><a href="http://www.ktrs.com/ktrs-the-big-550-newsletter-2016/">News Letter</a></li>
<li id="menu-item-57681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57681"><a href="http://www.ktrs.com/ktrs-cares/">KTRS Cares</a></li>
<li id="menu-item-57682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57682"><a href="http://www.ktrs.com/advertise-on-ktrs/">Advertise On KTRS</a></li>
<li id="menu-item-57683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57683"><a href="http://www.ktrs.com/ktrs-streaming/">Listen Now</a></li>
</ul></div></div></div>

		<div class="foot_clear"></div>		
		</div>
	
	</div>

	
	<!-- !Footer -->
	<footer id="footer" class="footer solid-bg">

		
			<div class="wf-wrap">
				<div class="wf-container-footer">
					<div class="wf-container">
						<section id="text-154" class="widget widget_text wf-cell wf-1-2"><div class="widget-title">FOLLOW US</div>			<div class="textwidget"><p><a href="https://www.facebook.com/550ktrs" target="_blank"><i class="fa fa-facebook"></i></a><a href="https://twitter.com/550KTRS" target="_blank"><i class="fa fa-twitter"></i></a><a href="https://soundcloud.com/user-423077123" target="_blank"><i class="fa fa-soundcloud"></i></a><br />
 </p>
<h3>DOWNLOAD OUR APP</h3>
<div><a href="https://play.google.com/store/apps/details?id=com.ktrs.player&#038;hl=en" target="_blank" rel="noopener"><img class="alignleft size-full wp-image-49161" src="http://ktrs.staging.wpengine.com/wp-content/uploads/2017/08/google-play-footer.png" alt="" width="277" height="96" /></a></div>
<div><a href="https://itunes.apple.com/us/app/ktrs-550/id508140494?mt=8" target="_blank" rel="noopener"><img class="alignleft size-full wp-image-49162" src="http://ktrs.staging.wpengine.com/wp-content/uploads/2017/08/app-store-footer.png" alt="" width="277" height="96" /></a></div>
</div>
		</section><section id="text-155" class="widget widget_text wf-cell wf-1-2"><div class="widget-title">JOIN THE MAILING LIST</div>			<div class="textwidget"><p><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-081711.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup" class="bottom-footer-mail">
<form action="//ktrs.us9.list-manage.com/subscribe/post?u=73d99b57cf8a09a99c7b3e683&#038;id=f9bdf2a099" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<div class="get-more-stuff">GET MORE STUFF<br />
in your inbox</div>
<p>	<label for="mce-EMAIL"></label><input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups--></p>
<div style="position: absolute; left: -5000px;"><input type="text" name="b_73d99b57cf8a09a99c7b3e683_f9bdf2a099" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</p></div>
</form>
</div>
<p><!--End mc_embed_signup--></p>
</div>
		</section>					</div><!-- .wf-container -->
				</div><!-- .wf-container-footer -->
			</div><!-- .wf-wrap -->

		
<!-- !Bottom-bar -->
<div id="bottom-bar" class="solid-bg logo-left" role="contentinfo">
	<div class="wf-wrap">
		<div class="wf-container-bottom">
			<div class="wf-table wf-mobile-collapsed">

				
				<div class="wf-td">

					
				</div>

				
					<div class="wf-td bottom-text-block">

						<p><!-- Widget Shortcode --></p>
<div id="nav_menu-10" class="widget widget_nav_menu">
<div class="menu-under-footer-menu-container">
<ul id="menu-under-footer-menu" class="menu">
<li id="menu-item-48686" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-48686"><a href="http://www.ktrs.com/">KTRS 550 HOME</a></li>
<li id="menu-item-48687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48687"><a href="http://www.ktrs.com/employment-opportunities/">JOBS</a></li>
<li id="menu-item-48688" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48688"><a href="http://www.ktrs.com/tos-and-privacy-policies/">TERMS OF SERVICE</a></li>
<li id="menu-item-48689" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48689"><a href="http://www.ktrs.com/privacy-policy/">PRIVACY POLICY</a></li>
<li id="menu-item-48690" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48690"><a href="http://www.ktrs.com/contact-ktrs/">CONTACT</a></li>
<li id="menu-item-48691" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48691"><a href="http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/uploads/2017/06/EEO-2014-2015-Public-File-Report.pdf">EEO 2014-2015</a></li>
</ul>
</div>
</div>
<p><!-- /Widget Shortcode --></p>

					</div>

				
			</div>
		</div><!-- .wf-container-bottom -->
	</div><!-- .wf-wrap -->
</div><!-- #bottom-bar -->
	</footer><!-- #footer -->



	<a href="#" class="scroll-top"><span class="screen-reader-text">Go to Top</span></a>

</div><!-- #page -->
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/themes/dt-the7/js/main.min.js?ver=6.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/www.ktrs.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/www.ktrs.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/www.ktrs.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.1'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.1.8'></script>
<script type='text/javascript' src='http://rbrua3v80lj2rulsf7iqfnpmf.wpengine.netdna-cdn.com/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-5').gslider({groupid:5,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-6').gslider({groupid:6,speed:6000,repeat_impressions:'Y'});
}});
</script>
<!-- /AdRotate JS -->


<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">
    <div class="pswp__bg"></div>
    <div class="pswp__scroll-wrap">
 
        <div class="pswp__container">
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
        </div>
 
        <div class="pswp__ui pswp__ui--hidden">
            <div class="pswp__top-bar">
                <div class="pswp__counter"></div>
                <button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
                <button class="pswp__button pswp__button--share" title="Share"></button>
                <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
                <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>
                <div class="pswp__preloader">
                    <div class="pswp__preloader__icn">
                      <div class="pswp__preloader__cut">
                        <div class="pswp__preloader__donut"></div>
                      </div>
                    </div>
                </div>
            </div>
            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
                <div class="pswp__share-tooltip"></div> 
            </div>
            <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
            </button>
            <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
            </button>
            <div class="pswp__caption">
                <div class="pswp__caption__center"></div>
            </div>
        </div>
    </div>
</div>
</body>
</html>