<!DOCTYPE html>
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" class="no-js">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0">
		<meta name="theme-color" content="#9aabb8"/>	<link rel="profile" href="http://gmpg.org/xfn/11" />
	        <script type="text/javascript">
            if (/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent)) {
                var originalAddEventListener = EventTarget.prototype.addEventListener,
                    oldWidth = window.innerWidth;

                EventTarget.prototype.addEventListener = function (eventName, eventHandler, useCapture) {
                    if (eventName === "resize") {
                        originalAddEventListener.call(this, eventName, function (event) {
                            if (oldWidth === window.innerWidth) {
                                return;
                            }
                            else if (oldWidth !== window.innerWidth) {
                                oldWidth = window.innerWidth;
                            }
                            if (eventHandler.handleEvent) {
                                eventHandler.handleEvent.call(this, event);
                            }
                            else {
                                eventHandler.call(this, event);
                            };
                        }, useCapture);
                    }
                    else {
                        originalAddEventListener.call(this, eventName, eventHandler, useCapture);
                    };
                };
            };
        </script>
		<title>Body Found in North City - KTRS | St Louis News and Talk Radio | The Big 550 AM</title>

<!-- This site is optimized with the Yoast SEO plugin v11.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.ktrs.com/body-found-in-north-city/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Body Found in North City - KTRS | St Louis News and Talk Radio | The Big 550 AM" />
<meta property="og:description" content="St. Louis, MO (KTRS) The body of a man is found in North City Wednesday night. Just before 6 o&#8217;clock, police responded to the 8300 block of Church Road in the Baden Neighborhood. Police are not saying how the man died, but homicide detectives are investigating." />
<meta property="og:url" content="https://www.ktrs.com/body-found-in-north-city/" />
<meta property="og:site_name" content="KTRS | St Louis News and Talk Radio | The Big 550 AM" />
<meta property="article:tag" content="8300 block of Church Road" />
<meta property="article:tag" content="Baden Neighborhood" />
<meta property="article:section" content="Home - Local" />
<meta property="article:published_time" content="2019-06-27T07:38:42+00:00" />
<meta property="article:modified_time" content="2019-06-27T07:38:54+00:00" />
<meta property="og:updated_time" content="2019-06-27T07:38:54+00:00" />
<meta property="og:image" content="https://www.ktrs.com/wp-content/uploads/2018/03/body-found_generic.jpg" />
<meta property="og:image:secure_url" content="https://www.ktrs.com/wp-content/uploads/2018/03/body-found_generic.jpg" />
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="225" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="St. Louis, MO (KTRS) The body of a man is found in North City Wednesday night. Just before 6 o&#8217;clock, police responded to the 8300 block of Church Road in the Baden Neighborhood. Police are not saying how the man died, but homicide detectives are investigating." />
<meta name="twitter:title" content="Body Found in North City - KTRS | St Louis News and Talk Radio | The Big 550 AM" />
<meta name="twitter:image" content="https://www.ktrs.com/wp-content/uploads/2018/03/body-found_generic.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.ktrs.com/#organization","name":"KTRS | The Big 550 AM","url":"https://www.ktrs.com/","sameAs":[]},{"@type":"WebSite","@id":"https://www.ktrs.com/#website","url":"https://www.ktrs.com/","name":"KTRS | St Louis News and Talk Radio | The Big 550 AM","publisher":{"@id":"https://www.ktrs.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.ktrs.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.ktrs.com/body-found-in-north-city/#primaryimage","url":"https://www.ktrs.com/wp-content/uploads/2018/03/body-found_generic.jpg","width":400,"height":225},{"@type":"WebPage","@id":"https://www.ktrs.com/body-found-in-north-city/#webpage","url":"https://www.ktrs.com/body-found-in-north-city/","inLanguage":"en-US","name":"Body Found in North City - KTRS | St Louis News and Talk Radio | The Big 550 AM","isPartOf":{"@id":"https://www.ktrs.com/#website"},"primaryImageOfPage":{"@id":"https://www.ktrs.com/body-found-in-north-city/#primaryimage"},"datePublished":"2019-06-27T07:38:42+00:00","dateModified":"2019-06-27T07:38:54+00:00"},{"@type":"Article","@id":"https://www.ktrs.com/body-found-in-north-city/#article","isPartOf":{"@id":"https://www.ktrs.com/body-found-in-north-city/#webpage"},"author":{"@id":"https://www.ktrs.com/author/news/#author"},"headline":"Body Found in North City","datePublished":"2019-06-27T07:38:42+00:00","dateModified":"2019-06-27T07:38:54+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.ktrs.com/body-found-in-north-city/#webpage"},"publisher":{"@id":"https://www.ktrs.com/#organization"},"image":{"@id":"https://www.ktrs.com/body-found-in-north-city/#primaryimage"},"keywords":"8300 block of Church Road,Baden Neighborhood","articleSection":"Home - Local,Home Slider Feature,Local"},{"@type":["Person"],"@id":"https://www.ktrs.com/author/news/#author","name":"News","image":{"@type":"ImageObject","@id":"https://www.ktrs.com/#authorlogo","url":"https://secure.gravatar.com/avatar/603f7f883b3cf36aa851fa17836421d2?s=96&d=mm&r=pg","caption":"News"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="KTRS | St Louis News and Talk Radio | The Big 550 AM &raquo; Feed" href="https://www.ktrs.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="KTRS | St Louis News and Talk Radio | The Big 550 AM &raquo; Comments Feed" href="https://www.ktrs.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="KTRS | St Louis News and Talk Radio | The Big 550 AM &raquo; Body Found in North City Comments Feed" href="https://www.ktrs.com/body-found-in-north-city/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ktrs.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='ch_css_base-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/contesthopper/css/ch_base.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='layerslider-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/LayerSlider/static/layerslider/css/layerslider.css?ver=6.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='livescore-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/personal-livescore/css/style.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='rt-tpg-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/the-post-grid-pro/assets/css/thepostgrid.css?ver=46' type='text/css' media='all' />
<link rel='stylesheet' id='rss-retriever-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/wp-rss-retriever/inc/css/rss-retriever.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='yop-public-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public.css?ver=5.1.1' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='vc_lte_ie9-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css?ver=6.0.2' type='text/css' media='screen' />
<![endif]-->
<link rel='stylesheet' id='dt-web-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A400%2C500%2C600%2C700&#038;ver=7.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='dt-main-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/themes/dt-the7/css/main.min.css?ver=7.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='dt-awsome-fonts-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/themes/dt-the7/fonts/FontAwesome/css/all.min.css?ver=7.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='dt-fontello-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/themes/dt-the7/fonts/fontello/css/fontello.min.css?ver=7.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='dt-custom-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/the7-css/custom.css?ver=7dfe1f72173a' type='text/css' media='all' />
<link rel='stylesheet' id='dt-media-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/the7-css/media.css?ver=7dfe1f72173a' type='text/css' media='all' />
<link rel='stylesheet' id='the7-mega-menu-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/the7-css/mega-menu.css?ver=7dfe1f72173a' type='text/css' media='all' />
<link rel='stylesheet' id='style-css'  href='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/themes/dt-the7-child/style.css?ver=7.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='sccss_style-css'  href='https://www.ktrs.com/?sccss=1&#038;ver=5.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var LS_Meta = {"v":"6.8.4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/LayerSlider/static/layerslider/js/greensock.js?ver=1.19.0'></script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/LayerSlider/static/layerslider/js/layerslider.kreaturamedia.jquery.js?ver=6.8.4'></script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/LayerSlider/static/layerslider/js/layerslider.transitions.js?ver=6.8.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var objectL10n = {"yopPollParams":{"urlParams":{"ajax":"https:\/\/www.ktrs.com\/wp-admin\/admin-ajax.php","wpLogin":"https:\/\/www.ktrs.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.ktrs.com%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":""}},"captchaParams":{"imgPath":"https:\/\/www.ktrs.com\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"https:\/\/www.ktrs.com\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Poll","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your vote"},"resultsParams":{"singleVote":"vote","multipleVotes":"votes"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public.min.js?ver=5.1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dtLocal = {"themeUrl":"https:\/\/www.ktrs.com\/wp-content\/themes\/dt-the7","passText":"To view this protected post, enter the password below:","moreButtonText":{"loading":"Loading...","loadMore":"Load more"},"postID":"69077","ajaxurl":"https:\/\/www.ktrs.com\/wp-admin\/admin-ajax.php","contactMessages":{"required":"One or more fields have an error. Please check and try again.","terms":"Please accept the privacy policy."},"ajaxNonce":"a0819ebe9d","pageData":"","themeSettings":{"smoothScroll":"off","lazyLoading":false,"accentColor":{"mode":"solid","color":"#9aabb8"},"desktopHeader":{"height":180},"floatingHeader":{"showAfter":94,"showMenu":false,"height":60,"logo":{"showLogo":true,"html":"","url":"https:\/\/www.ktrs.com\/"}},"topLine":{"floatingTopLine":{"logo":{"showLogo":false,"html":""}}},"mobileHeader":{"firstSwitchPoint":990,"secondSwitchPoint":0,"firstSwitchPointHeight":90,"secondSwitchPointHeight":60},"stickyMobileHeaderFirstSwitch":{"logo":{"html":"<img class=\" preload-me\" src=\"https:\/\/www.ktrs.com\/wp-content\/uploads\/2019\/01\/KTRS_TalkOfSTL_BANNER-MIZZOU.png\" srcset=\"https:\/\/www.ktrs.com\/wp-content\/uploads\/2019\/01\/KTRS_TalkOfSTL_BANNER-MIZZOU.png 1000w\" width=\"1000\" height=\"200\"   sizes=\"1000px\" alt=\"KTRS | St Louis News and Talk Radio | The Big 550 AM\" \/>"}},"stickyMobileHeaderSecondSwitch":{"logo":{"html":"<img class=\" preload-me\" src=\"https:\/\/www.ktrs.com\/wp-content\/uploads\/2018\/11\/Mizzou-at-Vanderbilt-header-.jpg\" srcset=\"https:\/\/www.ktrs.com\/wp-content\/uploads\/2018\/11\/Mizzou-at-Vanderbilt-header-.jpg 1024w\" width=\"1024\" height=\"121\"   sizes=\"1024px\" alt=\"KTRS | St Louis News and Talk Radio | The Big 550 AM\" \/>"}},"content":{"textColor":"#231f20","headerColor":"#231f20"},"sidebar":{"switchPoint":990},"boxedWidth":"1340px","stripes":{"stripe1":{"textColor":"#787d85","headerColor":"#3b3f4a"},"stripe2":{"textColor":"#8b9199","headerColor":"#ffffff"},"stripe3":{"textColor":"#ffffff","headerColor":"#ffffff"}}},"VCMobileScreenWidth":"768"};
var dtShare = {"shareButtonText":{"facebook":"Share on Facebook","twitter":"Tweet","pinterest":"Pin it","linkedin":"Share on Linkedin","whatsapp":"Share on Whatsapp","google":"Share on Google Plus"},"overlayOpacity":"85"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/themes/dt-the7/js/above-the-fold.min.js?ver=7.7.0'></script>
<meta name="generator" content="Powered by LayerSlider 6.8.4 - Multi-Purpose, Responsive, Parallax, Mobile-Friendly Slider Plugin for WordPress." />
<!-- LayerSlider updates and docs at: https://layerslider.kreaturamedia.com -->
<link rel='https://api.w.org/' href='https://www.ktrs.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ktrs.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ktrs.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.ktrs.com/?p=69077' />
<link rel="alternate" type="application/json+oembed" href="https://www.ktrs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ktrs.com%2Fbody-found-in-north-city%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ktrs.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ktrs.com%2Fbody-found-in-north-city%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.13.1 Professional to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-5 { margin:0px 0px 0px 0px;width:100%; max-width:360px; height:100%; max-height:360px; }
	.g-6 { margin:0px 0px 0px 0px;width:100%; max-width:1008px; height:100%; max-height:150px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
.adrotate_widgets, .ajdg_bnnrwidgets, .ajdg_grpwidgets { overflow:hidden; padding:0; }
</style>
<!-- /AdRotate CSS -->


<!-- Google Analytics by Lara - https://www.xtraorbit.com/wordpress-google-analytics-dashboard-widget/ -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-41742785-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-41742785-1', { 'anonymize_ip': true });
</script>
	
<script>
	jQuery(document).ready(function() {
        var rel = jQuery(".pl").attr("rel");
		jQuery("#online").load("http://www.ktrs.com/wp-content/plugins/personal-livescore/includes/pl-refresh.php?rel=" + rel);
		var refreshId = setInterval(function() {
			jQuery("#online").load("http://www.ktrs.com/wp-content/plugins/personal-livescore/includes/pl-refresh.php?randval=" + Math.random() + "&rel=" + rel);
		}, 600000);
	});
	</script>    <script type="text/javascript">
        if (typeof ajaxurl === "undefined") 
        var ajaxurl = 'https://www.ktrs.com/wp-admin/admin-ajax.php';
    </script>

<!-- BEGIN ExactMetrics v5.3.8 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-41742785-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END ExactMetrics Universal Analytics -->
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/
#comments{display:none;}		</style>
		<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><meta property="og:image" content="http://www.ktrs.com/wp-content/uploads/2017/12/KTRS_Square_Logo.jpg"/><style id='the7-custom-inline-css' type='text/css'>
/*----------header---------------*/

a.top_menu{font-size:26px!important; text-decoration:none!important;padding-top:10px;}





/*-----------sidebar form----------------------*/

.sidebar_button { width: 50%; }

.sidebar_email {  width: 80%; }

.foot_style {  background-color: #4996cf;  color: #000;  font-size: 16px; padding: 15px; }

.foot_style > h4 {  border-bottom: 1px solid #fff; color: #000; }



/*---------footer------------*/

.footer .widget-title { font-size: 24px; }

.fa { color: #fff;  font-size: 30px!important;  padding-right: 23px; }

.foot_form {  background-color: #b9d1e2;  color: #fff;  padding: 20px;  text-align: center; font-size: 20px; }

.email_style { width: 60%;  margin: 0 auto; }

.butt_style {  margin: 0 auto;  width: 30%; }

/*---------footer bottom----------*/

.menu-under-footer-menu-container ul li {  display: inline; border-style: none!important; }

.menu-under-footer-menu-container ul li a { font-size:17px; font-weight:bold; }

.menu-under-footer-menu-container {  padding-top: 20px;  margin-right: -44px; }

.footer .widget { margin-bottom:0px; }
</style>
</head>
<body class="post-template-default single single-post postid-69077 single-format-standard wp-embed-responsive dt-responsive-on srcset-enabled btn-flat custom-btn-color custom-btn-hover-color floating-mobile-menu-icon top-header first-switch-logo-left first-switch-menu-right second-switch-logo-left second-switch-menu-right right-mobile-menu layzr-loading-on popup-message-style the7-ver-7.7.0 wpb-js-composer js-comp-ver-6.0.2 vc_responsive">
<!-- The7 7.7.0 -->

<div id="page" >
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

<div class="masthead classic-header center bg-behind-menu logo-center widgets full-height line-decoration small-mobile-menu-icon mobile-menu-icon-bg-on dt-parent-menu-clickable show-mobile-logo" role="banner">

			<div class="top-bar">
			<div class="left-widgets mini-widgets"><div class="text-area show-on-desktop in-top-bar-left in-menu-second-switch"><p><a href="/ktrs-streaming/" class="top_menu">LISTEN LIVE NOW!</a></p>
</div></div>			<div class="right-widgets mini-widgets"><div class="soc-ico show-on-desktop in-top-bar-right in-menu-second-switch custom-bg disabled-border border-off hover-accent-bg hover-disabled-border  hover-border-off"><a title="Twitter" href="https://twitter.com/550KTRS" target="_blank" class="twitter"><span class="soc-font-icon"></span><span class="screen-reader-text">Twitter</span></a><a title="Facebook" href="https://www.facebook.com/550ktrs" target="_blank" class="facebook"><span class="soc-font-icon"></span><span class="screen-reader-text">Facebook</span></a><a title="Instagram" href="https://www.instagram.com/550ktrs/" target="_blank" class="instagram"><span class="soc-font-icon"></span><span class="screen-reader-text">Instagram</span></a><a title="SoundCloud" href="https://soundcloud.com/user-423077123" target="_blank" class="soundcloud"><span class="soc-font-icon"></span><span class="screen-reader-text">SoundCloud</span></a></div></div>		</div>

	<header class="header-bar">

						<div class="branding">
					<div id="site-title" class="assistive-text">KTRS | St Louis News and Talk Radio | The Big 550 AM</div>
					<div id="site-description" class="assistive-text">Your SUPER-powered St Louis Radio Station</div>
					<a class="" href="https://www.ktrs.com/"><img class=" preload-me" src="https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/2019/01/KTRS_TalkOfSTL_BANNER-MIZZOU.png" srcset="https://www.ktrs.com/wp-content/uploads/2019/01/KTRS_TalkOfSTL_BANNER-MIZZOU.png 1000w" width="1000" height="200"   sizes="1000px" alt="KTRS | St Louis News and Talk Radio | The Big 550 AM" /><img class="mobile-logo preload-me" src="https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/2018/11/Mizzou-at-Vanderbilt-header-.jpg" srcset="https://www.ktrs.com/wp-content/uploads/2018/11/Mizzou-at-Vanderbilt-header-.jpg 1024w" width="1024" height="121"   sizes="1024px" alt="KTRS | St Louis News and Talk Radio | The Big 550 AM" /></a>
					

					<div class="mini-widgets"></div>
					<div class="mini-widgets"></div>
				</div>
		<nav class="navigation">

			<ul id="primary-menu" class="main-nav underline-decoration l-to-r-line outside-item-remove-margin" role="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-57426 first has-children"><a href='http://www.ktrs.com/' data-level='1'><span class="menu-item-text"><span class="menu-text">Home</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57432 first"><a href='http://www.ktrs.com/about-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">About KTRS</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-57430 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-67460 first has-children"><a data-level='2'><span class="menu-item-text"><span class="menu-text">Weekday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58131 first"><a href='https://www.ktrs.com/weekday-shows/the-jim-bohannon-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Jim Bohannon Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58130"><a href='https://www.ktrs.com/first-light/' data-level='3'><span class="menu-item-text"><span class="menu-text">First Light</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58132"><a href='https://www.ktrs.com/farmer-dave/' data-level='3'><span class="menu-item-text"><span class="menu-text">AgriBiz with Farmer Dave</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49199 has-children"><a href='https://www.ktrs.com/mcgraw-milhaven/' data-level='3'><span class="menu-item-text"><span class="menu-text">The McGraw Show</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60628 first"><a href='https://www.ktrs.com/food-drink/' data-level='4'><span class="menu-item-text"><span class="menu-text">Food &#038; Drink</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49200 has-children"><a href='https://www.ktrs.com/the-inside/' data-level='3'><span class="menu-item-text"><span class="menu-text">Art &#038; Jennifer</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62010 first"><a href='https://www.ktrs.com/dreammakers/' data-level='4'><span class="menu-item-text"><span class="menu-text">DreamMakers</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49201"><a href='https://www.ktrs.com/john-carney/' data-level='3'><span class="menu-item-text"><span class="menu-text">The John Carney Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60663 has-children"><a href='https://www.ktrs.com/guy-phillips/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Guy Phillips Show</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61813 first"><a href='https://www.ktrs.com/tech-talk/' data-level='4'><span class="menu-item-text"><span class="menu-text">Tech Talk</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49204"><a href='http://www.ktrs.com/the-big-sports-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Big Sports Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68528"><a href='https://www.ktrs.com/in-the-know-with-ray-hartmann-and-jay-kanzler/' data-level='3'><span class="menu-item-text"><span class="menu-text">St. Louis In the Know with Ray Hartmann and Jay Kanzler</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-67461 has-children"><a href='http://www.ktrs.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Saturday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49212 first"><a href='https://www.ktrs.com/saturday-morning-wake-up/' data-level='3'><span class="menu-item-text"><span class="menu-text">Saturday Morning Wake Up</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49213"><a href='https://www.ktrs.com/550-yard-sale/' data-level='3'><span class="menu-item-text"><span class="menu-text">Walter Knoll Florist 550 Yard Sale</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49214"><a href='https://www.ktrs.com/purinas-animal-advice/' data-level='3'><span class="menu-item-text"><span class="menu-text">Purina&#8217;s Animal Advice</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49215"><a href='https://www.ktrs.com/straight-talk-on-retirement/' data-level='3'><span class="menu-item-text"><span class="menu-text">Straight Talk on Retirement</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49216"><a href='https://www.ktrs.com/inside-out/' data-level='3'><span class="menu-item-text"><span class="menu-text">Inside Out</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61757"><a href='https://www.ktrs.com/elder-talk/' data-level='3'><span class="menu-item-text"><span class="menu-text">Elder Talk with Joe Cordell</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62310"><a href='https://www.ktrs.com/girl-talk/' data-level='3'><span class="menu-item-text"><span class="menu-text">Girl Talk</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58125"><a href='https://www.ktrs.com/max-on-movies-2/' data-level='3'><span class="menu-item-text"><span class="menu-text">Max On Movies</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-67462 has-children"><a href='http://www.ktrs.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Sunday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49223 first"><a href='https://www.ktrs.com/having-a-senior-moment/' data-level='3'><span class="menu-item-text"><span class="menu-text">We&#8217;re Having a Senior Moment</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49225"><a href='https://www.ktrs.com/money-talk/' data-level='3'><span class="menu-item-text"><span class="menu-text">Money Talk</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49224"><a href='https://www.ktrs.com/mortgages-and-more/' data-level='3'><span class="menu-item-text"><span class="menu-text">Mortgages And More</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67551"><a href='https://www.ktrs.com/financial-tax-architects-retire-ready-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">Financial &#038; Tax Architects Retire Ready Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67594"><a href='https://www.ktrs.com/what-retirement-means-to-you/' data-level='3'><span class="menu-item-text"><span class="menu-text">What Retirement Means To You with Jerry Means</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60831"><a href='https://www.ktrs.com/when-retirement-happens/' data-level='3'><span class="menu-item-text"><span class="menu-text">When Retirement Happens</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49228"><a href='https://www.ktrs.com/this-week-in-real-estate/' data-level='3'><span class="menu-item-text"><span class="menu-text">This Week In Real Estate</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65455"><a href='https://www.ktrs.com/veterans-radio-network/' data-level='3'><span class="menu-item-text"><span class="menu-text">Veterans Radio Network</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64794"><a href='https://www.ktrs.com/retirement-and-income-radio/' data-level='3'><span class="menu-item-text"><span class="menu-text">Retirement and Income Radio</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64180"><a href='https://www.ktrs.com/the-circuit-of-success-with-brett-gilliland/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Circuit of Success with Brett Gilliland</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58128"><a href='https://www.ktrs.com/the-big-sports-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Big Sports Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49233"><a href='https://www.ktrs.com/outdoors-dan/' data-level='3'><span class="menu-item-text"><span class="menu-text">Outdoors Dan</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49229"><a href='https://www.ktrs.com/fairways-and-greens/' data-level='3'><span class="menu-item-text"><span class="menu-text">Fairways and Greens</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58126"><a href='https://www.ktrs.com/thanks-for-the-memories/' data-level='3'><span class="menu-item-text"><span class="menu-text">Thanks for the Memories</span></span></a></li> </ul></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49235 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">NEWS</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49236 first"><a href='https://www.ktrs.com/local/' data-level='2'><span class="menu-item-text"><span class="menu-text">Local News</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49237"><a href='https://www.ktrs.com/national/' data-level='2'><span class="menu-item-text"><span class="menu-text">National News</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59912"><a href='https://www.ktrs.com/news-staff/' data-level='2'><span class="menu-item-text"><span class="menu-text">News Staff</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49264 has-children"><a href='https://www.ktrs.com/sports/' data-level='1'><span class="menu-item-text"><span class="menu-text">Sports</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62011 first"><a href='https://www.milb.com/memphis' data-level='2'><span class="menu-item-text"><span class="menu-text">Memphis Redbirds</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60891"><a href='https://www.mlb.com/cardinals' data-level='2'><span class="menu-item-text"><span class="menu-text">St. Louis Cardinals</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60888"><a href='http://mutigers.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Mizzou</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60889"><a href='http://www.slubillikens.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Saint Louis Billikens</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60890"><a href='http://mvc-sports.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Missouri Valley Conference</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60892"><a href='https://www.nhl.com/blues' data-level='2'><span class="menu-item-text"><span class="menu-text">St. Louis Blues</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58172"><a href='https://www.ktrs.com/high-school-sports/' data-level='2'><span class="menu-item-text"><span class="menu-text">High School Sports</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-63912"><a href='http://www.ktrs.com/category/lifestyle/' data-level='1'><span class="menu-item-text"><span class="menu-text">Lifestyle</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49245 has-children"><a href='https://www.ktrs.com/events/' data-level='1'><span class="menu-item-text"><span class="menu-text">Events</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67870 first"><a href='https://www.ktrs.com/good-news-in-the-lou/' data-level='2'><span class="menu-item-text"><span class="menu-text">Good News in the Lou</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68080"><a href='https://www.ktrs.com/shop-local/' data-level='2'><span class="menu-item-text"><span class="menu-text">Shop Local</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49246"><a href='https://www.ktrs.com/contests/' data-level='2'><span class="menu-item-text"><span class="menu-text">Contests Details</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49247 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">Connect</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49248 first"><a href='https://www.ktrs.com/contact-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">Contact</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49251"><a href='https://www.ktrs.com/ktrs-cares/' data-level='2'><span class="menu-item-text"><span class="menu-text">KTRS Cares</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49252"><a href='https://www.ktrs.com/advertise-on-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">Advertise On KTRS</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57717"><a href='https://www.ktrs.com/ktrs-streaming/' data-level='1'><span class="menu-item-text"><span class="menu-text">LISTEN NOW</span></span></a></li> </ul>
			<div class="mini-widgets"><div class="mini-search show-on-desktop in-menu-first-switch in-menu-second-switch popup-search custom-icon">	<form class="searchform" role="search" method="get" action="https://www.ktrs.com/">

	<label for="search" class="screen-reader-text">Search:</label>
		<input type="text" class="field searchform-s" name="s" value="" placeholder="Type and hit enter &hellip;" />
				<input type="submit" class="assistive-text searchsubmit" value="Go!" />
		<a href="#go" id="trigger-overlay" class="submit text-disable">&nbsp;</a>
	</form></div></div>
		</nav>

	</header>

</div><div class='dt-close-mobile-menu-icon'><span></span></div>
<div class='dt-mobile-header'>
	<ul id="mobile-menu" class="mobile-main-nav" role="menu">
		<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-57426 first has-children"><a href='http://www.ktrs.com/' data-level='1'><span class="menu-item-text"><span class="menu-text">Home</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57432 first"><a href='http://www.ktrs.com/about-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">About KTRS</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-57430 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-67460 first has-children"><a data-level='2'><span class="menu-item-text"><span class="menu-text">Weekday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58131 first"><a href='https://www.ktrs.com/weekday-shows/the-jim-bohannon-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Jim Bohannon Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58130"><a href='https://www.ktrs.com/first-light/' data-level='3'><span class="menu-item-text"><span class="menu-text">First Light</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58132"><a href='https://www.ktrs.com/farmer-dave/' data-level='3'><span class="menu-item-text"><span class="menu-text">AgriBiz with Farmer Dave</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49199 has-children"><a href='https://www.ktrs.com/mcgraw-milhaven/' data-level='3'><span class="menu-item-text"><span class="menu-text">The McGraw Show</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60628 first"><a href='https://www.ktrs.com/food-drink/' data-level='4'><span class="menu-item-text"><span class="menu-text">Food &#038; Drink</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49200 has-children"><a href='https://www.ktrs.com/the-inside/' data-level='3'><span class="menu-item-text"><span class="menu-text">Art &#038; Jennifer</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62010 first"><a href='https://www.ktrs.com/dreammakers/' data-level='4'><span class="menu-item-text"><span class="menu-text">DreamMakers</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49201"><a href='https://www.ktrs.com/john-carney/' data-level='3'><span class="menu-item-text"><span class="menu-text">The John Carney Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-60663 has-children"><a href='https://www.ktrs.com/guy-phillips/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Guy Phillips Show</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61813 first"><a href='https://www.ktrs.com/tech-talk/' data-level='4'><span class="menu-item-text"><span class="menu-text">Tech Talk</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49204"><a href='http://www.ktrs.com/the-big-sports-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Big Sports Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68528"><a href='https://www.ktrs.com/in-the-know-with-ray-hartmann-and-jay-kanzler/' data-level='3'><span class="menu-item-text"><span class="menu-text">St. Louis In the Know with Ray Hartmann and Jay Kanzler</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-67461 has-children"><a href='http://www.ktrs.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Saturday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49212 first"><a href='https://www.ktrs.com/saturday-morning-wake-up/' data-level='3'><span class="menu-item-text"><span class="menu-text">Saturday Morning Wake Up</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49213"><a href='https://www.ktrs.com/550-yard-sale/' data-level='3'><span class="menu-item-text"><span class="menu-text">Walter Knoll Florist 550 Yard Sale</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49214"><a href='https://www.ktrs.com/purinas-animal-advice/' data-level='3'><span class="menu-item-text"><span class="menu-text">Purina&#8217;s Animal Advice</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49215"><a href='https://www.ktrs.com/straight-talk-on-retirement/' data-level='3'><span class="menu-item-text"><span class="menu-text">Straight Talk on Retirement</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49216"><a href='https://www.ktrs.com/inside-out/' data-level='3'><span class="menu-item-text"><span class="menu-text">Inside Out</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-61757"><a href='https://www.ktrs.com/elder-talk/' data-level='3'><span class="menu-item-text"><span class="menu-text">Elder Talk with Joe Cordell</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62310"><a href='https://www.ktrs.com/girl-talk/' data-level='3'><span class="menu-item-text"><span class="menu-text">Girl Talk</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58125"><a href='https://www.ktrs.com/max-on-movies-2/' data-level='3'><span class="menu-item-text"><span class="menu-text">Max On Movies</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-has-children menu-item-67462 has-children"><a href='http://www.ktrs.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Sunday Shows</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49223 first"><a href='https://www.ktrs.com/having-a-senior-moment/' data-level='3'><span class="menu-item-text"><span class="menu-text">We&#8217;re Having a Senior Moment</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49225"><a href='https://www.ktrs.com/money-talk/' data-level='3'><span class="menu-item-text"><span class="menu-text">Money Talk</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49224"><a href='https://www.ktrs.com/mortgages-and-more/' data-level='3'><span class="menu-item-text"><span class="menu-text">Mortgages And More</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67551"><a href='https://www.ktrs.com/financial-tax-architects-retire-ready-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">Financial &#038; Tax Architects Retire Ready Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67594"><a href='https://www.ktrs.com/what-retirement-means-to-you/' data-level='3'><span class="menu-item-text"><span class="menu-text">What Retirement Means To You with Jerry Means</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60831"><a href='https://www.ktrs.com/when-retirement-happens/' data-level='3'><span class="menu-item-text"><span class="menu-text">When Retirement Happens</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49228"><a href='https://www.ktrs.com/this-week-in-real-estate/' data-level='3'><span class="menu-item-text"><span class="menu-text">This Week In Real Estate</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65455"><a href='https://www.ktrs.com/veterans-radio-network/' data-level='3'><span class="menu-item-text"><span class="menu-text">Veterans Radio Network</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64794"><a href='https://www.ktrs.com/retirement-and-income-radio/' data-level='3'><span class="menu-item-text"><span class="menu-text">Retirement and Income Radio</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64180"><a href='https://www.ktrs.com/the-circuit-of-success-with-brett-gilliland/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Circuit of Success with Brett Gilliland</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58128"><a href='https://www.ktrs.com/the-big-sports-show/' data-level='3'><span class="menu-item-text"><span class="menu-text">The Big Sports Show</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49233"><a href='https://www.ktrs.com/outdoors-dan/' data-level='3'><span class="menu-item-text"><span class="menu-text">Outdoors Dan</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49229"><a href='https://www.ktrs.com/fairways-and-greens/' data-level='3'><span class="menu-item-text"><span class="menu-text">Fairways and Greens</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58126"><a href='https://www.ktrs.com/thanks-for-the-memories/' data-level='3'><span class="menu-item-text"><span class="menu-text">Thanks for the Memories</span></span></a></li> </ul></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49235 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">NEWS</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49236 first"><a href='https://www.ktrs.com/local/' data-level='2'><span class="menu-item-text"><span class="menu-text">Local News</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49237"><a href='https://www.ktrs.com/national/' data-level='2'><span class="menu-item-text"><span class="menu-text">National News</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59912"><a href='https://www.ktrs.com/news-staff/' data-level='2'><span class="menu-item-text"><span class="menu-text">News Staff</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49264 has-children"><a href='https://www.ktrs.com/sports/' data-level='1'><span class="menu-item-text"><span class="menu-text">Sports</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62011 first"><a href='https://www.milb.com/memphis' data-level='2'><span class="menu-item-text"><span class="menu-text">Memphis Redbirds</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60891"><a href='https://www.mlb.com/cardinals' data-level='2'><span class="menu-item-text"><span class="menu-text">St. Louis Cardinals</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60888"><a href='http://mutigers.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Mizzou</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60889"><a href='http://www.slubillikens.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Saint Louis Billikens</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60890"><a href='http://mvc-sports.com/' data-level='2'><span class="menu-item-text"><span class="menu-text">Missouri Valley Conference</span></span></a></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-60892"><a href='https://www.nhl.com/blues' data-level='2'><span class="menu-item-text"><span class="menu-text">St. Louis Blues</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-58172"><a href='https://www.ktrs.com/high-school-sports/' data-level='2'><span class="menu-item-text"><span class="menu-text">High School Sports</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-63912"><a href='http://www.ktrs.com/category/lifestyle/' data-level='1'><span class="menu-item-text"><span class="menu-text">Lifestyle</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49245 has-children"><a href='https://www.ktrs.com/events/' data-level='1'><span class="menu-item-text"><span class="menu-text">Events</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-67870 first"><a href='https://www.ktrs.com/good-news-in-the-lou/' data-level='2'><span class="menu-item-text"><span class="menu-text">Good News in the Lou</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68080"><a href='https://www.ktrs.com/shop-local/' data-level='2'><span class="menu-item-text"><span class="menu-text">Shop Local</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49246"><a href='https://www.ktrs.com/contests/' data-level='2'><span class="menu-item-text"><span class="menu-text">Contests Details</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49247 has-children"><a data-level='1'><span class="menu-item-text"><span class="menu-text">Connect</span></span></a><ul class="sub-nav hover-style-bg"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49248 first"><a href='https://www.ktrs.com/contact-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">Contact</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49251"><a href='https://www.ktrs.com/ktrs-cares/' data-level='2'><span class="menu-item-text"><span class="menu-text">KTRS Cares</span></span></a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49252"><a href='https://www.ktrs.com/advertise-on-ktrs/' data-level='2'><span class="menu-item-text"><span class="menu-text">Advertise On KTRS</span></span></a></li> </ul></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57717"><a href='https://www.ktrs.com/ktrs-streaming/' data-level='1'><span class="menu-item-text"><span class="menu-text">LISTEN NOW</span></span></a></li> 	</ul>
	<div class='mobile-mini-widgets-in-menu'></div>
</div>



<div id="main" class="sidebar-right sidebar-divider-off"  >

	
	<div class="main-gradient"></div>
	<div class="wf-wrap">
	<div class="wf-container-main">

	

			<div id="content" class="content" role="main">

				
<article id="post-69077" class="post-69077 post type-post status-publish format-standard has-post-thumbnail category-home-local category-home-slider-feature category-local tag-8300-block-of-church-road tag-baden-neighborhood category-15104 category-191 category-3 description-off">

	<div class="post-thumbnail"><img class="preload-me lazy-load" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20400%20200&#39;%2F%3E" data-src="https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/2018/03/body-found_generic.jpg" data-srcset="https://www.ktrs.com/wp-content/uploads/2018/03/body-found_generic.jpg 400w" width="400" height="200"  title="body-found_generic" alt="" /></div><div class="entry-content">
<p>St. Louis, MO (KTRS) The body of a man is found in North City Wednesday night. </p>



<p>Just before 6 o&#8217;clock, police responded to the 8300 block of Church Road in the Baden Neighborhood. </p>



<p>Police are not saying how the man died, but homicide detectives are investigating. </p>
</div><div class="single-related-posts"><h3>Related Posts</h3><section class="items-grid"><div class=" related-item"><article class="post-format-standard"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="https://www.ktrs.com/democrats-rail-against-economy-for-the-rich-in-first-debate/" aria-label="Post image"><img class="preload-me lazy-load" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/Democratic-primary-debate-hosted-by-NBC-News-110x80.jpg" data-srcset="https://www.ktrs.com/wp-content/uploads/2019/06/Democratic-primary-debate-hosted-by-NBC-News-110x80.jpg 110w, https://www.ktrs.com/wp-content/uploads/2019/06/Democratic-primary-debate-hosted-by-NBC-News-220x160.jpg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="https://www.ktrs.com/democrats-rail-against-economy-for-the-rich-in-first-debate/">Democrats Rail Against Economy-For-The-Rich in First Debate</a><br /><time class="text-secondary" datetime="2019-06-27T02:42:53-05:00">June 27, 2019</time></div></article></div><div class=" related-item"><article class="post-format-standard"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="https://www.ktrs.com/border-official-resigns-amid-uproar-over-migrant-children/" aria-label="Post image"><img class="preload-me lazy-load" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/acting-U.S.-Customs-and-Border-Protection-Commissioner-John-Sanders-110x80.jpg" data-srcset="https://www.ktrs.com/wp-content/uploads/2019/06/acting-U.S.-Customs-and-Border-Protection-Commissioner-John-Sanders-110x80.jpg 110w, https://www.ktrs.com/wp-content/uploads/2019/06/acting-U.S.-Customs-and-Border-Protection-Commissioner-John-Sanders-220x160.jpg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="https://www.ktrs.com/border-official-resigns-amid-uproar-over-migrant-children/">Border Official Resigns Amid Uproar Over Migrant Children</a><br /><time class="text-secondary" datetime="2019-06-26T02:42:54-05:00">June 26, 2019</time></div></article></div><div class=" related-item"><article class="post-format-standard"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="https://www.ktrs.com/funeral-arrangements-set-for-slain-police-officer/" aria-label="Post image"><img class="preload-me lazy-load" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/michael-langsdorf-1-110x80.jpg" data-srcset="https://www.ktrs.com/wp-content/uploads/2019/06/michael-langsdorf-1-110x80.jpg 110w, https://www.ktrs.com/wp-content/uploads/2019/06/michael-langsdorf-1-220x160.jpg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="https://www.ktrs.com/funeral-arrangements-set-for-slain-police-officer/">Funeral Arrangements Set for Slain Police Officer</a><br /><time class="text-secondary" datetime="2019-06-26T02:39:08-05:00">June 26, 2019</time></div></article></div><div class=" related-item"><article class="post-format-standard"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="https://www.ktrs.com/illinois-becomes-11th-state-to-allow-recreational-marijuana/" aria-label="Post image"><img class="preload-me lazy-load" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/Pritzker-Pot-Law-110x80.jpg" data-srcset="https://www.ktrs.com/wp-content/uploads/2019/06/Pritzker-Pot-Law-110x80.jpg 110w, https://www.ktrs.com/wp-content/uploads/2019/06/Pritzker-Pot-Law-220x160.jpg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="https://www.ktrs.com/illinois-becomes-11th-state-to-allow-recreational-marijuana/">Illinois becomes 11th state to allow recreational marijuana</a><br /><time class="text-secondary" datetime="2019-06-25T12:43:52-05:00">June 25, 2019</time></div></article></div><div class=" related-item"><article class="post-format-standard"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="https://www.ktrs.com/police-release-more-than-1000-files-from-smollett-probe/" aria-label="Post image"><img class="preload-me lazy-load" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/2019/06/image-made-from-police-body-cam-video-provided-by-the-Chicago-Police-Department-purports-to-show-Jussie-Smollett-with-a-white-rope-wrapped-around-his-neck-110x80.jpg" data-srcset="https://www.ktrs.com/wp-content/uploads/2019/06/image-made-from-police-body-cam-video-provided-by-the-Chicago-Police-Department-purports-to-show-Jussie-Smollett-with-a-white-rope-wrapped-around-his-neck-110x80.jpg 110w, https://www.ktrs.com/wp-content/uploads/2019/06/image-made-from-police-body-cam-video-provided-by-the-Chicago-Police-Department-purports-to-show-Jussie-Smollett-with-a-white-rope-wrapped-around-his-neck-220x160.jpg 220w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="https://www.ktrs.com/police-release-more-than-1000-files-from-smollett-probe/">Police Release More Than 1,000 Files From Smollett Probe</a><br /><time class="text-secondary" datetime="2019-06-25T02:17:23-05:00">June 25, 2019</time></div></article></div><div class=" related-item"><article class="post-format-standard"><div class="mini-post-img"><a class="alignleft post-rollover layzr-bg" href="https://www.ktrs.com/jury-convicts-christensen-in-murder-of-chinese-scholar/" aria-label="Post image"><img class="preload-me lazy-load" src="data:image/svg+xml,%3Csvg%20xmlns%3D&#39;http%3A%2F%2Fwww.w3.org%2F2000%2Fsvg&#39;%20viewBox%3D&#39;0%200%20110%2080&#39;%2F%3E" data-src="https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/uploads/2017/09/Yingying-Zhang.jpg" data-srcset="https://www.ktrs.com/wp-content/uploads/2017/09/Yingying-Zhang.jpg 110w" width="110" height="80"  alt="" /></a></div><div class="post-content"><a href="https://www.ktrs.com/jury-convicts-christensen-in-murder-of-chinese-scholar/">Jury Convicts Christensen in Murder of Chinese Scholar</a><br /><time class="text-secondary" datetime="2019-06-25T01:54:11-05:00">June 25, 2019</time></div></article></div></section></div>
</article>

	<div id="comments" class="comments-area">

	
		
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/body-found-in-north-city/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in text-small">You must be <a href="https://www.ktrs.com/wp-login.php?redirect_to=https%3A%2F%2Fwww.ktrs.com%2Fbody-found-in-north-city%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
	</div><!-- #comments .comments-area -->

			</div><!-- #content -->

			
	<aside id="sidebar" class="sidebar solid-bg">
		<div class="sidebar-content widget-divider-off">
			<section id="text-129" class="widget widget_text">			<div class="textwidget"></div>
		</section>		</div>
	</aside><!-- #sidebar -->


			</div><!-- .wf-container -->
		</div><!-- .wf-wrap -->
	</div><!-- #main -->
    
    
    <div class="footer_q_l footer">
		<div class="inner wf-wrap">

			<div class="col_g_4"><div class="widget-title">Weekday Shows</div><div class="menu-footer-menu-column1-container"><ul id="menu-footer-menu-column1" class="menu"><li id="menu-item-57484" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57484"><a href="https://www.ktrs.com/weekday-shows/the-jim-bohannon-show/">The Jim Bohannon Show</a></li>
<li id="menu-item-57485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57485"><a href="https://www.ktrs.com/first-light/">First Light</a></li>
<li id="menu-item-57486" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57486"><a href="https://www.ktrs.com/farmer-dave/">Farmer Dave</a></li>
<li id="menu-item-57487" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57487"><a href="https://www.ktrs.com/mcgraw-milhaven/">McGraw Milhaven</a></li>
<li id="menu-item-57488" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57488"><a href="https://www.ktrs.com/the-inside/">Art &#038; Jennifer</a></li>
<li id="menu-item-57489" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57489"><a href="https://www.ktrs.com/john-carney/">The Carney Show</a></li>
<li id="menu-item-57491" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57491"><a href="https://www.ktrs.com/fox-2-news/">FOX 2 News</a></li>
<li id="menu-item-57492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57492"><a href="http://www.ktrs.com/the-big-sports-show/">The Big Sports Show</a></li>
<li id="menu-item-57494" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57494"><a href="https://www.ktrs.com/all-access-with-josh-gilbert/">The After Show with Josh Gilbert</a></li>
<li id="menu-item-57495" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57495"><a href="https://www.ktrs.com/ktrs-news-staff/">KTRS News Staff</a></li>
<li id="menu-item-57496" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57496"><a href="https://www.ktrs.com/paul-harris/">Paul Harris</a></li>
<li id="menu-item-57497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57497"><a href="https://www.ktrs.com/doug-mcelvein/">Doug McElvein</a></li>
</ul></div></div>
			<div class="col_g_4"><div class="widget-title">Saturday Shows</div><div class="menu-footer-menu-column2-container"><ul id="menu-footer-menu-column2" class="menu"><li id="menu-item-57558" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57558"><a href="https://www.ktrs.com/saturday-morning-wake-up/">Saturday Morning Wake Up</a></li>
<li id="menu-item-57559" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57559"><a href="https://www.ktrs.com/550-yard-sale/">Walter Knoll Florist 550 Yard Sale</a></li>
<li id="menu-item-57560" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57560"><a href="https://www.ktrs.com/purinas-animal-advice/">Purina’s Animal Advice</a></li>
<li id="menu-item-57561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57561"><a href="https://www.ktrs.com/straight-talk-on-retirement/">Straight Talk on Retirement</a></li>
<li id="menu-item-57562" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57562"><a href="https://www.ktrs.com/inside-out/">Inside Out</a></li>
<li id="menu-item-57563" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57563"><a href="https://www.ktrs.com/when-retirement-happens/">America’s Wealth Management</a></li>
<li id="menu-item-57564" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57564"><a href="https://www.ktrs.com/retire-worry-free/">Retire Worry Free</a></li>
<li id="menu-item-57565" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57565"><a href="https://www.ktrs.com/growing-green-st-louis/">Growing Green St. Louis</a></li>
</ul></div></div>
			<div class="col_g_4"><div class="widget-title">Sunday Shows</div><div class="menu-footer-menu-column3-container"><ul id="menu-footer-menu-column3" class="menu"><li id="menu-item-57657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57657"><a href="https://www.ktrs.com/having-a-senior-moment/">We’re Having a Senior Moment</a></li>
<li id="menu-item-57658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57658"><a href="https://www.ktrs.com/money-talk/">Money Talk</a></li>
<li id="menu-item-57659" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57659"><a href="https://www.ktrs.com/mortgages-and-more/">Mortgages And More</a></li>
<li id="menu-item-57661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57661"><a href="https://www.ktrs.com/when-retirement-happens/">America’s Wealth Management</a></li>
<li id="menu-item-57662" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57662"><a href="https://www.ktrs.com/this-week-in-real-estate/">This Week In Real Estate</a></li>
<li id="menu-item-57663" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57663"><a href="https://www.ktrs.com/fairways-and-greens/">Fairways and Greens</a></li>
<li id="menu-item-57665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57665"><a href="https://www.ktrs.com/freedom-investing-lifestyle/">Freedom Investing Lifestyle</a></li>
<li id="menu-item-57666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57666"><a href="https://www.ktrs.com/the-budweiser-big-bbq-show/">The Budweiser Big BBQ Show</a></li>
<li id="menu-item-57667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57667"><a href="https://www.ktrs.com/outdoors-dan/">Outdoors Dan</a></li>
</ul></div></div>
			<div class="col_g_4 last"><div class="widget-title">News</div><div class="menu-footer-menu-column4-container"><ul id="menu-footer-menu-column4" class="menu"><li id="menu-item-57671" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57671"><a href="https://www.ktrs.com/local/">Local News</a></li>
<li id="menu-item-57672" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57672"><a href="https://www.ktrs.com/national/">National News</a></li>
</ul></div><div class="sec"><div class="widget-title">Sports</div><div class="menu-footer-menu-column4-sports-container"><ul id="menu-footer-menu-column4-sports" class="menu"><li id="menu-item-57674" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57674"><a href="http://www.ktrs.com/saint-louis-fc/">Saint Louis FC</a></li>
<li id="menu-item-57675" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57675"><a href="http://www.ktrs.com/category/sports/st-louis-university-billikens/">SLU Billikens</a></li>
<li id="menu-item-57676" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57676"><a href="http://www.ktrs.com/category/sports/st-louis-blues-hockey/">St Louis Blues Hockey</a></li>
<li id="menu-item-57677" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57677"><a href="http://www.ktrs.com/mizzou-tigers/">Mizzou Tigers</a></li>
</ul></div></div><div class="third"><div class="widget-title">Connects</div><div class="menu-footer-menu-column5-container"><ul id="menu-footer-menu-column5" class="menu"><li id="menu-item-57678" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57678"><a href="https://www.ktrs.com/contact-ktrs/">Contact KTRS</a></li>
<li id="menu-item-57680" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57680"><a href="http://www.ktrs.com/ktrs-the-big-550-newsletter-2016/">News Letter</a></li>
<li id="menu-item-57681" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57681"><a href="https://www.ktrs.com/ktrs-cares/">KTRS Cares</a></li>
<li id="menu-item-57682" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57682"><a href="https://www.ktrs.com/advertise-on-ktrs/">Advertise On KTRS</a></li>
<li id="menu-item-57683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57683"><a href="https://www.ktrs.com/ktrs-streaming/">Listen Now</a></li>
</ul></div></div></div>

		<div class="foot_clear"></div>		
		</div>
	
	</div>

	
	<!-- !Footer -->
	<footer id="footer" class="footer solid-bg">

		
			<div class="wf-wrap">
				<div class="wf-container-footer">
					<div class="wf-container">
						<section id="text-154" class="widget widget_text wf-cell wf-1-2"><div class="widget-title">FOLLOW US</div>			<div class="textwidget"><p>&nbsp;</p>
<h3>DOWNLOAD OUR APP</h3>
<div><a href="https://play.google.com/store/apps/details?id=com.ktrs1.player" target="_blank" rel="noopener"><img class="alignleft size-full wp-image-49161" src="https://ktrs.staging.wpengine.com/wp-content/uploads/2017/08/google-play-footer.png" alt="" width="277" height="96" /></a></div>
<div><a href="https://itunes.apple.com/us/app/ktrs-550/id508140494?mt=8" target="_blank" rel="noopener"><img class="alignleft size-full wp-image-49162" src="https://ktrs.staging.wpengine.com/wp-content/uploads/2017/08/app-store-footer.png" alt="" width="277" height="96" /></a></div>
</div>
		</section><section id="text-155" class="widget widget_text wf-cell wf-1-2"><div class="widget-title">JOIN THE MAILING LIST</div>			<div class="textwidget"><p><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-081711.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup" class="bottom-footer-mail">
<form action="//ktrs.us9.list-manage.com/subscribe/post?u=73d99b57cf8a09a99c7b3e683&#038;id=f9bdf2a099" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
<div id="mc_embed_signup_scroll">
<div class="get-more-stuff">GET MORE STUFF<br />
in your inbox</div>
<p>	<label for="mce-EMAIL"></label><input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required><!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups--></p>
<div style="position: absolute; left: -5000px;"><input type="text" name="b_73d99b57cf8a09a99c7b3e683_f9bdf2a099" tabindex="-1" value=""></div>
<div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
</p></div>
</form>
</div>
<p><!--End mc_embed_signup--></p>
</div>
		</section>					</div><!-- .wf-container -->
				</div><!-- .wf-container-footer -->
			</div><!-- .wf-wrap -->

			
<!-- !Bottom-bar -->
<div id="bottom-bar" class="solid-bg logo-left" role="contentinfo">
	<div class="wf-wrap">
		<div class="wf-container-bottom">
			<div class="wf-table wf-mobile-collapsed">

				
					<div class="wf-td">
						<div class="wf-float-left">

							Copyright 2018 KTRS The Big 550 - All Rights Reserved
						</div>
					</div>

				
				<div class="wf-td">

					
				</div>

				
					<div class="wf-td bottom-text-block">

						<p><!-- Widget Shortcode --></p>
<div id="nav_menu-10" class="widget widget_nav_menu widget-shortcode area-arbitrary">
<div class="menu-under-footer-menu-container">
<ul id="menu-under-footer-menu" class="menu">
<li id="menu-item-48686" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-48686"><a href="http://www.ktrs.com/">KTRS |</a></li>
<li id="menu-item-48687" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48687"><a href="http://www.ktrs.com/employment-opportunities/">JOBS |</a></li>
<li id="menu-item-48688" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48688"><a href="http://www.ktrs.com/tos-and-privacy-policies/">TERMS OF SERVICE |</a></li>
<li id="menu-item-48689" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48689"><a href="http://www.ktrs.com/privacy-policy/">PRIVACY POLICY |</a></li>
<li id="menu-item-48690" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48690"><a href="http://www.ktrs.com/contact-ktrs/">CONTACT |</a></li>
<li id="menu-item-48691" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48691"><a href="https://publicfiles.fcc.gov/am-profile/ktrs/equal-employment-opportunity-records/additional-documents/eeo-public-file-reports/1287918e-faa7-f99e-6cbd-ba211247e165/">EEO PUBLIC FILES  |</a></li>
<li id="menu-item-66140" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66140"><a href="https://publicfiles.fcc.gov/am-profile/ktrs">PUBLIC INSPECTION FILE</a></li>
</ul>
</div>
</div>
<p><!-- /Widget Shortcode --></p>

					</div>

				
			</div>
		</div><!-- .wf-container-bottom -->
	</div><!-- .wf-wrap -->
</div><!-- #bottom-bar -->
	</footer><!-- #footer -->



	<a href="#" class="scroll-top"><span class="screen-reader-text">Go to Top</span></a>

</div><!-- #page -->
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/themes/dt-the7/js/main.min.js?ver=7.7.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/www.ktrs.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.ktrs.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/adrotate-pro/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ktrs.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.3'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.1.8'></script>
<script type='text/javascript' src='https://rbrua3v80lj2rulsf7iqfnpmf-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=5.1.1'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){if(jQuery.fn.gslider) {
	jQuery('.g-5').gslider({groupid:5,speed:6000,repeat_impressions:'Y'});
	jQuery('.g-6').gslider({groupid:6,speed:10000,repeat_impressions:'Y'});
}});
</script>
<!-- /AdRotate JS -->


<div class="pswp" tabindex="-1" role="dialog" aria-hidden="true">
    <div class="pswp__bg"></div>
    <div class="pswp__scroll-wrap">
 
        <div class="pswp__container">
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
            <div class="pswp__item"></div>
        </div>
 
        <div class="pswp__ui pswp__ui--hidden">
            <div class="pswp__top-bar">
                <div class="pswp__counter"></div>
                <button class="pswp__button pswp__button--close" title="Close (Esc)"></button>
                <button class="pswp__button pswp__button--share" title="Share"></button>
                <button class="pswp__button pswp__button--fs" title="Toggle fullscreen"></button>
                <button class="pswp__button pswp__button--zoom" title="Zoom in/out"></button>
                <div class="pswp__preloader">
                    <div class="pswp__preloader__icn">
                      <div class="pswp__preloader__cut">
                        <div class="pswp__preloader__donut"></div>
                      </div>
                    </div>
                </div>
            </div>
            <div class="pswp__share-modal pswp__share-modal--hidden pswp__single-tap">
                <div class="pswp__share-tooltip"></div> 
            </div>
            <button class="pswp__button pswp__button--arrow--left" title="Previous (arrow left)">
            </button>
            <button class="pswp__button pswp__button--arrow--right" title="Next (arrow right)">
            </button>
            <div class="pswp__caption">
                <div class="pswp__caption__center"></div>
            </div>
        </div>
    </div>
</div>
</body>
</html>